Unable to change loginname from username to e-mail using active directory backend

Hello again,

I am unable to change the default login from username to (main) email address.

I edited ldap_loginname_attribute in ldap.active-directory.cfg.
I tried ldap_loginname_attribute = userPrincipalName and also ldap_loginname_attribute = mail but neither brought some change and I still could only login with name only.

Should this work or is this the wrong option? I guess I could change loginname_format = %u to loginname_format = %u@mydomain.com in server.cfg but that should be everything but best practice…

Thanks in advance

Hi @gladston3 ,

do you maybe have sync_gab_realtime set to no and did not execute a kopano-admin --sync after you ldap change? or are you maybe running user_safe_mode = yes?

Did you make your change in the correct ldap.active-directory.cfg? With 8.2 there was a change in the organisation of the ldap configuration, the new default behaviour is to have an ldap.cfg which includes a standard configuration and changes should be done in ldap.cfg. If you started with an earlier version you current configuration will stay compatible of course.

Hi @fbartels,

My sync_gab_realtime is set to yes and my user_safe_mode to no both in /etc/kopano/server.cfg.

I did not start with a version <8.2.
I have two ldap configuration files in my /etc/kopano folder. ldap.cfg and ldap.active-directory.cfg which I copied from /usr/share/kopano and then adjusted to my setup.

In the ldap.cfg file there is an include line for ldap.active-directory.cfg and some basic settings but nothing I could identify as “login name change variable”.
I only found ldap_loginname_attribute in the ldap.active-directory.cfg in the “# There should be no need to edit any values below this line” section.

So are you suggesting to just write the ldap_loginname_attribute into the ldap.cfg file or is the whole ldap.active-directory.cfg depricated?

I can also post my config files if you need them. Just let me know.


No, since the ldap.active-directory.cfg is included from ldap.cfg it should not matter where you change the value (as long as you don’t overwrite it through a later include).

Yes pasting your complete config may help.

Okay, it’s pretty embarassing but sometimes I am just dumb. I edited /etc/kopano/ldap.active-directory.cfg while /usr/share/kopano/ldap.active-directory.cfg was included in ldap.cfg.

I followed your advice now and put my settings at the end of ldpa.cfg and it works like a charm now.

Thank you for your help and sorry again for my dumbness :D


  • gladston3
Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.