Ubuntu 18.04 Installation Problems

Hello!
I try to set up a new Ubuntu 18.04 server to migrate from my old 14.04.
One of the first things I try ist to install Kopano, so I can migrate my old Zarafa.
But unfortunately there is a problem I can not fix.
This is how I have tried to install Kopano:

cd /root/install/kopano
wget https://download.kopano.io/community/core:/core-8.6.80.760_0%2B90-Ubuntu_18.04-amd64.tar.gz
tar xfvz core-8.6.80.760_0+90-Ubuntu_18.04-amd64.tar.gz
cd core-8.6.80.760_0+90-Ubuntu_18.04-amd64
dpkg -i *.deb
apt-get install -f

dpkg -i *.deb
###
# Lots of Messages, ends with:
Fehler traten auf beim Bearbeiten von:
 libjansson-doc
 python2-kopano
###
apt-get install -f
apt --fix-broken install
apt-get install libjs-backbone

dpkg -i *.deb
###
# Lots of Messages, ends with:
Fehler traten auf beim Bearbeiten von:
 python2-kopano
###

# Unfortunately I could not fix this.
# But this seems odd to me, look at the version numbers of the first two files:
ls -lisah python*
1310783  96K -rw-r--r-- 1 25122 users  93K Apr 11 01:18 python2-kopano_8.6.80.538-0+56.1_all.deb
1310784  96K -rw-r--r-- 1 25122 users  93K Apr 11 01:18 python3-kopano_8.6.80.538-0+56.1_all.deb
1310785 100K -rw-r--r-- 1 25122 users 100K Mai  7 15:02 python3-kopano_8.6.80.760-0+90.1_all.deb
1310744 272K -rw-r--r-- 1 25122 users 270K Mai  7 15:02 python3-mapi_8.6.80.760-0+90.1_amd64.deb
1310782  16K -rw-r--r-- 1 25122 users  13K Mai  7 15:02 python-kopano_8.6.80.760-0+90.1_all.deb
1310742  16K -rw-r--r-- 1 25122 users  13K Mai  7 15:02 python-mapi_8.6.80.760-0+90.1_amd64.deb

You can see, there are:

  • python-kopano and python-mapi
  • python3-kopano and python3-mapi
  • python2-kopano and no python2-mapi, but an additional python3-kopano-file

So, to me it seems, that version 8.6.80.760 was packed with wrong python2-files.
Am I right with my guess? When can we have a new version with correct python2-files?

PS:
There are two more files of version 8.6.80.538:

ls -lisah *8.6.80.538*
1310777 60K -rw-r--r-- 1 25122 users 60K Apr 11 01:18 kopano-lang_8.6.80.538-0+56.1_all.deb
1310779 16K -rw-r--r-- 1 25122 users 13K Apr 11 01:18 kopano-server-packages_8.6.80.538-0+56.1_all.deb
1310783 96K -rw-r--r-- 1 25122 users 93K Apr 11 01:18 python2-kopano_8.6.80.538-0+56.1_all.deb
1310784 96K -rw-r--r-- 1 25122 users 93K Apr 11 01:18 python3-kopano_8.6.80.538-0+56.1_all.deb

I always recommend to rather create a local repository to install from, instead of installing via dpkg -i *. If you search the forum you will find some ways to generate such a repository.

In regards to the python packages. As mentioned in https://forum.kopano.io/topic/1383/kopano-download-no-core-nighty-builds we are sorting these issues out at the moment, a fix is expected for next week.

Thank you for your reply, I have tried to create a local repository, but it won’t work.
So I tried the fresh version from today and installed it a little differend, and no error occures (even if there still seems to be a problem with Python2-Mapi package):

"cd /root/install/kopano
wget https://download.kopano.io/community/core:/core-8.6.80.859_0%2B121-Ubuntu_18.04-amd64.tar.gz
tar xfvz core-8.6.80.859_0+121-Ubuntu_18.04-amd64.tar.gz
cd core-8.6.80.859_0+121-Ubuntu_18.04-amd64
apt-get install libjs-backbone libjansson-doc
dpkg -i *.deb
apt-get install -f
apt install kopano-server-packages
"

@deringo said in Ubuntu 18.04 Installation Problems:

even if there still seems to be a problem with Python2-Mapi package

Can you explain a bit further what kind of error you are seeing?

@fbartels
The python2-mapi.deb is still missing.

dpkg -i *.deb
## Output:
[...]
libvmime-kopano1 (0.9.2+14.10) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von python2-kopano:
 python2-kopano hängt ab von python2-mapi; aber:
  Paket python2-mapi ist nicht installiert.
 python-kopano (8.6.80.859-0+121.1) beschädigt python2-kopano und ist entpackt, aber nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes python2-kopano (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
tidy-html5 (5.1.9+3.10) wird eingerichtet ...
[...]
Fehler traten auf beim Bearbeiten von:
 python2-kopano
###

ls -lisah python*
1310863  96K -rw-r--r-- 1 25122 users  93K Apr 11 01:18 python2-kopano_8.6.80.538-0+56.1_all.deb
1310864  96K -rw-r--r-- 1 25122 users  93K Apr 11 01:18 python3-kopano_8.6.80.538-0+56.1_all.deb
1310865 100K -rw-r--r-- 1 25122 users 100K Mai 23 12:40 python3-kopano_8.6.80.859-0+121.1_all.deb
1310824 264K -rw-r--r-- 1 25122 users 264K Mai 23 12:40 python3-mapi_8.6.80.859-0+121.1_amd64.deb
1310862 100K -rw-r--r-- 1 25122 users 100K Mai 23 12:40 python-kopano_8.6.80.859-0+121.1_all.deb
1310822 268K -rw-r--r-- 1 25122 users 265K Mai 23 12:40 python-mapi_8.6.80.859-0+121.1_amd64.deb

yes, but that is correct. In the debian world there are usually no packages with the name python2-something, so we switched back to python-mapi and python-kopano for the python2 variants.

@fbartels since you have started building again the packages I would like to know if the problem is solved now, since the most recent .tar.gz for Ubuntu 18.04 still contains an old python2-mapi …

Hi @General_Probe ,

the problem should indeed be resolved. It seems there was there a residual python2*.deb package (as evidence of the old version tag) in the directory where the archives are created from. I’ve now manually deleted it, so it should be gone from the next upload.