Building mmc-plugin from source



  • Hello,

    I am trying to build the mmc-plugin from source which seems to work so far. I am kinda stuck with the CreateInstallScript though. I tried to create a script with it plus InstallTemplate but when I try to run the created script I am getting an error that an “AI_GetMsiProperty” Cmdlet is not found/missing.
    After some google search I found out that this Cmdlet seems to belong to “Advanced Installer”. I installed “Advanced Installer” but the Cmdlet is still missing. Am I forced to use that software somehow to build a msi or is there another possibility?

    Thank you very much in advance
    Cheers
    -gladston3


  • Kopano

    Hello @gladston3,

    forum user @darootler has contributed some compiling instructions a while back, which I have now put into the official manual (with small modifications). You can find them at https://documentation.kopano.io/kopanocore_administrator_manual/compiling_from_source.html#installing-kopano-mmc-snap-in-from-source

    The advanced installer is only really necessary, when you need an installable package, for most home users this is not needed, therefore I would recommend to not create the msi and install the addin directly.



  • Hi @fbartels ,

    wow very nice, thank you and also @darootler. Definately gonna try this out in the evening.
    I never planned to build a msi installer. Just was not sure in the end if I have to due to this strange error with the missing cmdlet.

    Thanks again and I will keep you updated
    cheers
    -gladston3



  • Hey @fbartels,

    edit:

    Okay, I found the error myself…

    gacutil.exe -u stands for uninstall. So this is actually not going to work if you do not have a previous (?) version of the mmc plugin installed.

    So I continued with the following steps ignoring the errors with gacutil.exe -u

    RegAsm.exe KopanoADS.dll
    gacutil.exe -i Tulpep.ActiveDirectoryObjectPicker.dll
    gacutil.exe -i KopanoADS.dll
    

    After those steps the Kopano tabs were available.

    Maybe this helps some others (:

    @fbartels I totally understand the considerations behind not offering everything as a compiled version. But I am honestly not sure if this actually really helps your company.
    Take me for an example. I really want to get rid of Exchange at my SMB customers. So I tried and I am still trying out alot of the usual alternatives and I am totally willing to pay for support for most of my customers.
    Kopano sounds very good and promising and I also like the open source approach. On the other hand I found very bad and angry critics about your software on some sites (e.g. debian forums). So I am somehow forced to test it first. And I really need to test it over a couple of months and with active directory integration and z-push and so on.
    I already almost gave up twice and I do not have much yet. It took me already more time to get the AD integration done than it took me with your competitor with Z to install everything and get it running.
    And I am definately a linux native, who knows how to configure postfix etc…
    I know your arguments that you want to keep all options open for your clients, but I honestly think it would be a good idea to ease the (test) installation a little bit more and maybe overthink the no compiling strategy.
    Yes I know you have this UCS point & click option but that is not really an option for a longer test, since I definately wil not use UCS in production. So it would not be the brightest idea to do my testing there.
    So all in all I think you are losing a lot of potential customers because of the big installation hurdles for the open source version. I totally understand your ideas behind it but I also think that many interested people will not just buy support if the are unable to install it in the first place but simply move on to another competitor.

    If you do not agree (at all) it is fine for me. Just wanted to make my point clear (;

    cheers
    -gladston3



  • Hi there!

    I’m trying to install the mmc-plugin myself with little/no success so far…
    The compile/build went without an issue.
    I successfully extended the AD schema.
    I’m trying to install the mmc-plugin on a Windows 7 SP1 machine with the RSAT tools installed and working.

    In the “AD Users and Computers” tool the Kopano tabs simply won’t show up.
    In the context menu there are some new “actions” like “new kopano address list, Kopano dynamic address list” etc but no kopano “details” tabs on the objects.
    Once the “address lists” objects are created there is no kopano tabs either.

    Any idea what could be wrong?

    Regards,
    MCulibrk



  • Hey,

    I cannot really help you on this, because I did not use a native Windows Domain Controller but a Samba 4 DC. Also I more or less gave up and switched to another solution mainly due to the lack of proper documentation and the lack of any GUI configuration possibilities (second one was more a concern of my collegues, though^^).

    Cheers
    -gladston3



  • Thanks for your answer!

    I suspect there is some missing steps/info in the “install by hand” procedure.
    I somehow miss the part which actually “registers” all the “extensions/tabs” to be used by the DSA.MSC tool.
    I see that “part” in the “installTemplate/installDebug.ps” scripts… but I’m missing the “SHEETS” array/something to do it by hand…
    I could be wrong… and maybe the RegAsm does that but I’m not sure… have to check in registry.

    I agree with you regarding “missing UI parts”… even the “user” part is rather limited (mmc plugin and a LAM (ldap account manager) - all windows only…
    The is something included in the UCS but there are other problems there…
    For the server part… yeah, nothing. But ok, that part is not that problematic as I see it…

    What really bothers me with Kopano “configs” is the total lack of “SMTP” config - mainly Postfix (or other solution). And spam, filtering and related stuff…

    May I ask you what did you choose as a solution?
    I’m currently using Communigate Pro which has a lot (too much “unrelated”) features but is also missing some “nice/integrated” spam/filtering option and, the main problem - web clients/desktop clients and slooooow operation on searches (through web clients), constant problems with the outlook mapi plugin/client etc.
    I was evaluating Zimbra & Kopano and (for now) leaned toward Kopano for its “simplicity”, nice, feature-full web client, active-sync support etc.

    I hope @fbartels could give some hints regarding the AD/MMC integration…

    Thanks!
    Regards,
    mculibrk



  • Hey,

    as mentioned before I never tried it on a Microsoft DC and on Samba the script (which is/was a different one went through fine). What I was asking myself back then though was, if I really want to do such deep (scripted) modifications to a production AD/DC…

    I personally am fine with server parts without UI but there are many collegues who don’t like it at all and I can understand their side (at least a little bit ;)). Also I was short before giving up many times due to the lack of documentation in some areas. I really think that they still want to push you to the subscription version.

    I don’t like UCS at all. So I never tried Kopano on it…

    Postfix and spamfiltering was not a real problem for me because I know postfix quite well and also did a lot with spamassassin and amavis. But you really need to know what you are doing there and that’s another point where I think it’s not that appealing for most people. If you have a specific question on postfix though, I can probably help you out.

    I really don’t know if it’s allowed to discuss alternatives here, but I went with the solution you mentioned before Kopano eventually and I even use it in production in one setup. It’s quite solid, the installation is much easier than Kopano and the server side configuration backend is quite nice. Ther you can also integrate it into AD quite nicely and without any changes in AD. They also offer a desktop client and a webclient. Both don’t look as much as outlook as the kopano versions do but it’s okay. It also has postfix and a spamfilter out of the box and configured and you can edit it via the server gui. For what I saw they use quite the newest/best software (nginx, postfix, etc…) and not like many others old stuff (apache, exim, etc…).

    Where kopano definitely has its advantages though, is with active sync and outlook integration. It both works with the other solution too, but the outlook plugin from kopano gives you many advantages and z-push is made by the kopano/zarafa guys as far as I know and is just adapted for the other solution. In my setup it works, but I have no clue if it changes with heavier workloads.

    You could also try invis server which seems to have kopano integrated but I never tried that myself. Also Suse seems to have pre build packages and debian is working on them.


  • Kopano

    @mculibk said in Building mmc-plugin from source:

    I hope @fbartels could give some hints regarding the AD/MMC integration…

    I am not a windows developer myself, so i cannot help much on that topic. but we are currently discussing on making automated master builds available to the public, i suppose that would also be a way to solve you problem.


  • Kopano

    @mculibk a nightly build is now available from https://download.kopano.io/community/adextension:/



  • Wow!!!
    Great!

    I’ll try and let you know it that worked for me…

    THANX!

    Regards,
    MCulibrk



  • :(

    The install process fails… as far as I understand it fails because of a “missing” RegAsm64… but the machine is running a 32-bit OS (Win7 SP1 + RSAT tools installed)

    I’ll try to install it on a 64-bit OS to see if that solves the problem…

    Are there any other requirements for this MSI to install? Like ldif tools, gacutil, regasm… tools and utilities? Should I install something first (as the installer is not complaining about “missing prerequisites”…

    I’m unable to upload files (“images”) here (permission issues - a popup says) so I’m including a link to the install log if that could help you or other developers.

    kopano-install.log



  • The install completed successfully on a 64-bit Win2008 R2 system…
    It seems all nice & easy… but… the result is the same as before - nothing “happens”.

    When editing (existing or freshly created user or inetorgperson object) there are no “Kopano tabs”.
    The context-menu (right-button click) shows new items under “new” - kopanoAddressLists and kopanoDynamicAddressLists…

    To me it seems like some “registration” missing (register various tabs/pages under the DSA.MSC user admin tool).
    As I mentioned… I saw those registrations in the scripts (source code) but I’m not sure how/who should run those (it cannot be just run from command line because there are missing bits)

    0_1500553805524_Screenshot_user.png
    0_1500553825311_Screenshot_addrlist.png
    0_1500553893101_Screenshot_new.png

    So, basically, there is no difference between this “fancy/nice” installer and the build-from-source variants, at least for me…

    Any more ideas?


  • Kopano

    Hm… I will need to check in with the developer for this, sadly he is currently not in, so I can only check with him in the middle of next week.



  • @fbartels thanks for your time & efforts!

    No problem… I’ll wait… as I’m running out of ideas…
    If I’ll find enough time I’ll try to configure a “lab” environment with a “standalone” AD server, with fresh AD and then try to install/configure things there…

    As there is no logs or errors or anything I have no idea where/what to look for. I checked the registry and I think all the classes and guides are registered/configured there - so this should be ok.
    Maybe the problem is with the AD (schema) or something… as I “managed to screw” the production AD with the “UCS bidirectional synchronization” (what a mess it was… still “recovering” when some issues appear here and there)… after that the Kopano schema extensions seemed like “it cannot make things worst than they already are”…

    And all this because I could not find any other “nice” tool for editing the LDAP kopano objects… managing all the user stuff through AD seemed a “nice/logical option”…


  • Kopano

    Hi @mculibk ,

    I have discussed this with the developer of our ad extension. Since you are running in Samba he also pointed me towards the kopano_schema_add.sh script in https://stash.kopano.io/projects/KC/repos/kopano-ads-source/browse/samba/kopano-samba-ads

    But looking at your screenshots executing this as it is, will probably not give you the desired tabs. Windows seems to have a restriction where tabs must be registered for every locale and judging from your screenshots (and the email you registered for the forum with) you seem to be from Slovenia, which is a locale we currently do not register.

    You could do two things here: either change your windows locale to us english, or modify linked script in line https://stash.kopano.io/projects/KC/repos/kopano-ads-source/browse/samba/kopano-samba-ads/kopano_schema_add.sh#36 to include the windows locale for Slovenia (this would then be the value 424)

    Regards



  • Hi there @fbartels !

    Thanks for your time and efforts with this…

    I supposed it was related to some kind of “registration”… and yes, you’re right, I have the Slovenian locale on the Win7 machine but it should be English on the server side. Anyway, I tried to re-install the thing (the msi package) but the result is exactly the same - it installs successfully but no additional tabs are shown in the object editor (DSA - Users and Computers).

    I checked the Configuration “partition” of the AD, especially the “display specifiers” section and I cannot find any “mention” of Kopano objects or extensions and I checked the English (409) and some other locales - nothing.

    I’m willing to register all those pages myself by hand… the only problem is I’m not so sure what is to be registered “where”.
    I found the “kopano-ads.ldf” schema extensions where only the object extensions are defined, no display specifiers.
    Then I found the “InstallTemplate.ps1” script which seems responsible for registering all the stuff in Windows but I’m “missing” (not understanding) where is the “<SHEETS>” variable/array/list/file defined?
    I also found the “Sheets.cs” script/source with some GUID/pages reference but I’m not so sure if that’s the right file too look at.

    Oh, sorry… only now, that you mentioned “Samba install” I went through the script and found there all the references just about the thing I’m talking about (property pages, names, guids…) - I was constantly skipping this part as I’m working with a “native” Windows AD environment, no Samba DC etc… I really hope the GUIDs/pages/IDs are the same and that I can just execute the script (or do it by hand, now that I see the missing linking info).
    Can you confirm the “config” is exactly the same for “native” AD or Samba AD?

    Also… I think there is a little bug in the MSI install script… it fails on 32-bit systems… :)
    I know, I know… “who is still using 32-bit OS-es”… but anyway…
    When I created some links (Framework64 --> Framework and RegAsm64.exe --> RegAsm.exe) the installation went through (but no property pages displayed, no change in Configuration schema).

    Shouldn’t the MSI update the schema in the install process?

    (I did not jet try to install the MSI on a 64-bit Win 2012 English)

    Thanks for all your time!
    Regards,
    mculibrk


  • Kopano

    @mculibk ah, my bad I thought you said you are running samba4, but that was @gladston3 . but in that case you should not run the script.

    @mculibk said in Building mmc-plugin from source:

    Also… I think there is a little bug in the MSI install script… it fails on 32-bit systems

    yes, we don’t support 32bit systems and only test for 64bit. if you want to submit a patch we can review and potentially include it.

    since you primary language in windows is not english, it probably does not register for you. you’d either need to switch to an english locale or adapt the installer to install for your locale. at least thats how i understood the developer.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.