Outlook 2016 client stopped working with syncing



  • Dear all,

    I’m running a subscribed Kopano system with a few outlook 2016 clients since a couple of days (all others are pending to be migrated from Zarafa backend to kopano).
    Since this evening, the outlook clients can’t sync anymore with the server. I get the following log entries in z-push:

    02/05/2018 20:58:11 [ 1463] [FATAL] [cdj] FatalMisconfigurationException: Not possible to write to the configured state directory. - code: 0 - file: /usr/share/z-push/lib/default/filestatemachine.php:63
    02/05/2018 20:58:11 [ 1463] [FATAL] [cdj] Exception: (FatalMisconfigurationException) - Not possible to write to the configured state directory.
    02/05/2018 21:02:11 [ 1464] [FATAL] [cdj] FatalMisconfigurationException: Not possible to write to the configured state directory. - code: 0 - file: /usr/share/z-push/lib/default/filestatemachine.php:63

    I also found back the following earlier today(just warning - although I didn’t have it before today)
    :02/05/2018 18:42:52 [23432] [WARN] [#unknown] /usr/share/z-push/lib/utils/utils.php:714 strftime(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone ‘UTC’ for now, but please set date.timezone to select your timezone. (2)

    any ideas on how to fix it?

    regards,
    Joost


  • Kopano

    Hi Joost,

    is the state directory writable to the webserver user? Is it on a shared disc which maybe wasn’t available for some time?

    You can set timezone in the config.php of Z-Push. Just change the value of TIMEZONE (line 30).

    Manfred



  • Hi Manfred. I executed the z-push-admin '-a list -u <username>. It worked fine for the first user. However, executing the same command for the second user generated the following error:

    FatalException: FixFileOwner: /var/log/z-push must be owned by the nginx/apache/php user instead of root

    If I check the /var/log directory I get the following:
    drwxrwx—. 2 root z-push 48 May 2 21:33 z-push
    the content is:
    -rw-r–r--. 1 root z-push 27M May 2 21:33 z-push-error.log
    -rw-r–r--. 1 root root 1.2K May 2 21:33 z-push.log

    if I look at /var/lib/z-push
    drwxrwx—. 9 root z-push 98 Apr 30 23:33 z-push

    in the directory I see:
    drwxrwx—. 9 root z-push 98 Apr 30 23:33 .
    drwxr-xr-x. 32 root root 4.0K Dec 14 18:23 …
    drwxr-xr-x. 5 apache apache 33 Apr 30 23:33 1
    drwxr-xr-x. 3 apache apache 15 Apr 11 17:17 3
    drwxr-xr-x. 3 apache apache 15 Apr 29 23:31 5
    drwxr-xr-x. 3 apache apache 15 Apr 29 17:20 6
    drwxr-xr-x. 4 apache apache 24 Apr 29 19:06 9
    drwxr-xr-x. 3 apache apache 15 Oct 14 2017 a
    drwxr-xr-x. 3 apache apache 15 Apr 11 17:17 e
    -rw-r–r--. 1 apache apache 28 Oct 14 2017 settings
    -rw-r–r--. 1 root z-push 539 Apr 30 23:33 users



  • btw disc is local on the same server. I checked and no disconnect happened


  • Kopano

    Hi Joost,

    yes, the ownership is wrong. Based on your post it should be apache.apache for /var/log/z-push and /var/lib/z-push. You can change the permissions recursively for those two directories.

    We’ve addressed this issue in https://jira.z-hub.io/browse/ZP-1399 which will be part of the next Z-Push 2.4.2 release.

    Manfred



  • Hi Manfred,

    thanks. Resetting the permissions fixed the problem !!
    Many thanks for the quick reply.
    regards,
    Joost


Log in to reply