Update 8.5 -> 8.6 blocked



  • Hi - I admit it, my Kopano installation have not got much attention lately and I just sort of ignored that zypper have refused to update my installation for quite some time.

    I am running Kopano on a OpenSUSE 42.3 from the sever:/mail:/kopano reository

    Well I today I tried to convince zypper to perform the update using the command

    sudo zypper dup --from server_mail_kopano
    

    This gave me the following options:

    3 Problems:
    Problem: python-mapi-8.5.0.0-64.3.x86_64 requires kopano-client = 8.5.0.0, but this requirement cannot be provided
    Problem: python-mapi-8.5.0.0-64.3.x86_64 requires libkcfreebusy.so.0(KC_8.5)(64bit), but this requirement cannot be provided
    Problem: kopano-presence-8.5.0.0-64.3.x86_64 requires python-kopano = 8.5.0.0, but this requirement cannot be provided
    
    Problem: python-mapi-8.5.0.0-64.3.x86_64 requires kopano-client = 8.5.0.0, but this requirement cannot be provided
      deleted providers: kopano-client-8.5.0.0-64.3.x86_64
     Solution 1: Following actions will be done:
      keep obsolete kopano-client-8.5.0.0-64.3.x86_64
      keep obsolete libkcmapi0-8.5.0.0-64.3.x86_64
      keep obsolete libkcsync0-8.5.0.0-64.3.x86_64
      keep obsolete libkcutil0-8.5.0.0-64.3.x86_64
      keep obsolete libmapi1-8.5.0.0-64.3.x86_64
      keep obsolete kopano-common-8.5.0.0-64.3.x86_64
      keep obsolete kopano-lang-8.5.0.0-64.3.x86_64
      keep obsolete libkcsoap0-8.5.0.0-64.3.x86_64
      keep obsolete libkcssl0-8.5.0.0-64.3.x86_64
     Solution 2: deinstallation of python-mapi-8.5.0.0-64.3.x86_64
     Solution 3: break python-mapi-8.5.0.0-64.3.x86_64 by ignoring some of its dependencies
    
    

    It seems that kopano-presence is not in the 8.6 repository. So before I go ahead and just remove kopano-presence and python-mapi I would like to have the Kopano community opinion on how to proceed.

    Regards
    Klaus


Log in to reply