Errors and Warnings since 2.4.1 update

Hi,

since updating to 2.4.1 we see this errors and warnings in z-push-error.log:

12/04/2018 17:58:38 [ 4085] [ERROR] [wh] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command 'Sync' at 12/04/2018 17:58:32 with pid '2073' terminated unexpectedly or is still running.
12/04/2018 17:58:38 [ 4085] [ERROR] [wh] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.
12/04/2018 17:59:09 [ 4091] [WARN] [wh] /usr/share/z-push/backend/kopano/mapiprovider.php:2258 mapi_zarafa_getuser_by_name(): Unable to resolve the user: 8004010F (2)
12/04/2018 17:59:09 [ 4091] [WARN] [wh] SyncObject->Check(): object from type SyncMail: parameter 'to' contains an invalid email address '"Alle in der Firma angestellten" <>'. Address is removed.
12/04/2018 17:59:24 [ 4095] [WARN] [wh] /usr/share/z-push/backend/kopano/mapiprovider.php:2258 mapi_zarafa_getuser_by_name(): Unable to resolve the user: 8004010F (2)
12/04/2018 17:59:24 [ 4095] [WARN] [wh] SyncObject->Check(): object from type SyncMail: parameter 'to' contains an invalid email address '"Alle in der Firma angestellten" <>'. Address is removed.
12/04/2018 17:59:44 [ 4092] [WARN] [wh] /usr/share/z-push/backend/kopano/mapiprovider.php:2258 mapi_zarafa_getuser_by_name(): Unable to resolve the user: 8004010F (2)

Any ideas how to solve this issues?

Hi WalterHof,

the first two error message are always together. Are there any errors in apache logs? It also can be that you simply have long running Sync requests. Please also check z-push.log for pid 2073 if it terminated.

mapi_zarafa_getuser_by_name WARNs - emails or meeting requests from a kopano user who is no longer available (maybe deleted). Have you also updated kopano recently?

SyncObject->Check() WARNs - quite self-explanatory. It’s not a valid email address and this is in the code for quite some time, not only since Z-Push 2.4.1.

Are there a lot of these errors in the log or only the ones you posted?

Manfred

Manfred,

this are the last lines of apache2/error.log:

[Thu Apr 12 17:58:32.971016 2018] [mpm_prefork:notice] [pid 1800] AH00170: caught SIGWINCH, shutting down gracefully
PHP Fatal error:  Cannot call overloaded function for non-object in /usr/share/z-push/lib/core/topcollector.php on line 117
PHP Warning:  (Registered shutdown functions) Unable to call zpush_fatal_handler() - function does not exist in Unknown on line 0
[Thu Apr 12 17:58:33.182181 2018] [ssl:warn] [pid 4077] AH01873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Apr 12 17:58:33.246768 2018] [mpm_prefork:notice] [pid 4077] AH00163: Apache/2.4.23 (Linux/SUSE) OpenSSL/1.0.2j-fips configured -- resuming normal operations
[Thu Apr 12 17:58:33.246851 2018] [core:notice] [pid 4077] AH00094: Command line: '/usr/sbin/httpd-prefork -D SYSCONFIG -D SSL -C PidFile /var/run/httpd.pid -C Include /etc/apache2/sysconfig.d//loadmodule.conf -C Include /etc/apache2/sysconfig.d//global.conf -f /etc/apache2/httpd.conf -c Include /etc/apache2/sysconfig.d//include.conf -D SYSTEMD -D FOREGROUND'

Have you also updated kopano recently?
System is on 8.5.5 with backup issue.

Are there a lot of these errors in the log or only the ones you posted?
About 20 lines.

Walter

Hi Walter,

which OS and PHP versions are on your system? Are you using Apache APC? Are any another Apache or PHP mods enabled?

Manfred

SLES 12 SP3.
No other Modules enabled.

Hi Walter,

what about my other questions/notes?

Please also check z-push.log for pid 2073 if it terminated.

Which PHP version is on your system?

I’m not familiar how SUSE does it, but could you post which apache modules are enabled?

Are you running other web applications on that server?

Has the system high load?

Manfred

Hi Manfred,

  • Please also check z-push.log for pid 2073 if it terminated.
12/04/2018 17:54:29 [ 2073] [FATAL] [wh] FatalMisconfigurationException: Not possible to write to the configured state directory. - code: 0 - file: /usr/share/z-push/lib/default/filestatemachine.php:63
12/04/2018 17:54:29 [ 2073] [ INFO] [wh] User-agent: 'unknown'
12/04/2018 17:54:29 [ 2073] [FATAL] [wh] Exception: (FatalMisconfigurationException) - Not possible to write to the configured state directory.
12/04/2018 17:54:29 [ 2073] [ INFO] [wh] cmd='Sync' memory='1.64 MiB/2.00 MiB' time='0.01s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='500'
12/04/2018 17:54:31 [ 2073] [FATAL] [wh] FatalMisconfigurationException: Not possible to write to the configured state directory. - code: 0 - file: /usr/share/z-push/lib/default/filestatemachine.php:63
12/04/2018 17:54:31 [ 2073] [ INFO] [wh] User-agent: 'unknown'
12/04/2018 17:54:31 [ 2073] [FATAL] [wh] Exception: (FatalMisconfigurationException) - Not possible to write to the configured state directory.
12/04/2018 17:54:31 [ 2073] [ INFO] [wh] cmd='Sync' memory='1.64 MiB/2.00 MiB' time='0.00s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='500'

btw. z-push 2.4.1 update changed owner of all z-push directories to root:root so manually I changed owner back to wwwrun:www .

12/04/2018 17:58:21 [ 2073] [WARN] [wh] /usr/share/z-push/backend/kopano/mapiprovider.php:2258 mapi_zarafa_getuser_by_name(): Unable to resolve the user: 8004010F (2)
12/04/2018 17:58:21 [ 2073] [WARN] [wh] SyncObject->Check(): object from type SyncMail: parameter 'to' contains an invalid email address '"Alle in der Firma angestellten" <>'. Address is removed.
12/04/2018 17:58:21 [ 2073] [ INFO] [wh] cmd='Sync' memory='4.60 MiB/5.00 MiB' time='1.16s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='200'
12/04/2018 17:58:22 [ 2073] [ INFO] [wh] cmd='Sync' memory='2.73 MiB/3.25 MiB' time='0.12s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='200'
12/04/2018 17:58:24 [ 2073] [ INFO] [wh] cmd='Sync' memory='4.60 MiB/5.00 MiB' time='1.12s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='200'
12/04/2018 17:58:25 [ 2073] [ INFO] [wh] cmd='Sync' memory='2.73 MiB/3.25 MiB' time='0.12s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='200'
12/04/2018 17:58:26 [ 2073] [ INFO] [wh] cmd='Sync' memory='4.60 MiB/5.00 MiB' time='1.15s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='200'
12/04/2018 17:58:27 [ 1900] [ INFO] [wh] cmd='Sync' memory='2.69 MiB/3.00 MiB' time='0.12s' devType='iPhone' devId='ssekri0vcp1i9ajvldu58gagms' getUser='wh' from='192.168.130.10' idle='0s' version='2.4.1+0' method='POST' httpcode='200'

12/04/2018 17:58:38 [ 4085] [ERROR] [wh] LoopDetection->ProcessLoopDetectionPreviousConnectionFailed(): Command 'Sync' at 12/04/2018 17:58:32 with pid '2073' terminated unexpectedly or is still running.
12/04/2018 17:58:38 [ 4085] [ERROR] [wh] Please check your logs for this PID and errors like PHP-Fatals or Apache segmentation faults and report your results to the Z-Push dev team.

  • Which PHP version is on your system?
    php5-5.5.14-109.24.1.x86_64
  • I’m not familiar how SUSE does it, but could you post which apache modules are enabled?
APACHE_MODULES="actions alias auth_basic authn_file authz_host authz_groupfile authz_user authn_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir proxy proxy_http authnz_ldap mod_ldap authn_core authz_core php5 headers deflate version"
  • Are you running other web applications on that server?
    Only Kopano WebApp latest version.

  • Has the system high load?
    No

Hi Walter,

so, the first two errors from your initial post were related to the missing folder permissions.

@walterhof said in Errors and Warnings since 4.2.1 update:

btw. z-push 2.4.1 update changed owner of all z-push directories to root:root so manually I changed owner back to wwwrun:www .

No, we changed it to root:z-push and the z-push group has the write permissions to those folders. We also add the wwwrun user to the z-push group.

Manfred

No, we changed it to root:z-push and the z-push group has the write permissions to those folders. We also add the wwwrun user to the z-push group.

chown root:z-push -R /var/log/z-push/

 z-push-top
FatalException: FixFileOwner: /var/log/z-push must be owned by the nginx/apache/php user instead of root

Hi Walter,

I’ve created a JIRA issue for the wrong ownership/permissions: https://jira.z-hub.io/browse/ZP-1399.

Manfred

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.