User Company quotas problem

Hi ,
When setting user quotas at company level only the “Warning level” gets populated:

Current user store quota settings:
 Quota overrides:       yes
 Warning level:         1.00 MB
 Soft level:            unlimited
 Hard level:            unlimited

I have tested the ldap query manually (taken from the server.log) and everything seems right:

root@kopanoserver:/home/local# ldapsearch -H ldaps://kopano-dc.kopano.test.local -D "cn=Kopano LDAP,ou=Kopano,dc=kopano,dc=test,dc=local" -W -b "dc=kopano,dc=test,dc=local" -s sub "(&(&(kopanoAccount=1)(objectClass=kopanoCompany))(ou=\45\6D\70\72\65\73\61\20\4F\6C\61))" kopanoUserDefaultQuotaOverride kopanoUserDefaultQuotaWarn kopanoUserDefaultQuotaSoft kopanoUserDefaultQuotaHard
Enter LDAP Password:
# extended LDIF
#
# LDAPv3
# base <dc=kopano,dc=test,dc=local> with scope subtree
# filter: (&(&(kopanoAccount=1)(objectClass=kopanoCompany))(ou=\45\6D\70\72\65\73\61\20\4F\6C\61))
# requesting: kopanoUserDefaultQuotaOverride kopanoUserDefaultQuotaWarn kopanoUserDefaultQuotaSoft kopanoUserDefaultQuotaHard
#

# Empresa Ola, kopano.test.local
dn: OU=Empresa Ola,DC=kopano,DC=test,DC=local
kopanoUserDefaultQuotaSoft: 3
kopanoUserDefaultQuotaWarn: 1
kopanoUserDefaultQuotaOverride: 1
kopanoUserDefaultQuotaHard: 5

# search reference
ref: ldaps://ForestDnsZones.kopano.test.local/DC=ForestDnsZones,DC=kopano,DC=t
 est,DC=local

# search reference
ref: ldaps://DomainDnsZones.kopano.test.local/DC=DomainDnsZones,DC=kopano,DC=t
 est,DC=local

# search reference
ref: ldaps://kopano.test.local/CN=Configuration,DC=kopano,DC=test,DC=local

# search result
search: 2
result: 0 Success

# numResponses: 5
# numEntries: 1
# numReferences: 3```

I’m using Kopano server 8.6.80.400-0+48.1 with Windows 2012R2 as the LDAP backend.

Hi,

we see the same issue. There is a service request open but answer was: works as designed.

@WalterHof can you point me to the ticket where a ticket was closed with “works as expected”?

I was only able to find https://jira.kopano.io/browse/KC-843, which is on “info needed” since we still need to define the expected behaviour (very few requests, so not top on the list).

We have ticket [KS-39209] open, and discussed this issue an some other quota problems with support. Answer on phone as, works as designed and have no priority.

Yes, that is what I though. KS-39209 is about setting a quota on a public store, not about inheriting quota from the tenant to the users. Setting a hard quota on the public store is indeed something we do not want to do (so it works as designed), since denying access to the public store can lead to side effects in the client.

What @nbj was describing on the other hand sounds like a big (the one I linked) to me. For this we’ll need to sit down internally and define the expected behaviour.

You stated:
“Setting a hard quota on the public store is indeed something we do not want to do (so it works as designed), since denying access to the public store can lead to side effects in the client.Setting a hard quota on the public store is indeed something we do not want to do (so it works as designed), since denying access to the public store can lead to side effects in the client.”

Unfortunately if you have customer to pay for a specific mailbox size, this customers move all there mails to public store and pay only for smallest mailbox. In this case we need quotas on public store to.

Walter

@walterhof said in User Company quotas problem:

In this case we need quotas on public store too

We are further going away from the initial topic.

While automatic limitation of the public store is nothing that is going to happen, its quite easy to monitor x tenants and just remind them friendly to reduce their public store size (with the soft limit this should actually already be the case). And if they don’t reduce, then send them a non automated mail.

This is IMHO not an issue that needs to be solved in Kopano.