kopano archiver error

I tried to set up the kopano archiver and got some problems

first one:
After first archiving, a new store was attached to my user with all old mails in the correct folders.

But after looking into the database i found out that the archiv store is not in the archiv database. The store is in the server database.

Why is the archiv not stored in the archiv database?

second one:

It is not possible to delete or create folders in archiv. Why?

third one:

what sould be inserted into the kopanoUserArchiveServers attribute in LDAP. I could not find a description for it?

Server Debian 8 with core-8.5.81.224_0+29-Debian_8.0-amd64 and webapp-3.4.10.1330+755-Debian_8.0-all

config:

##############################################################
# ARCHIVER SETTINGS

# Server Unix socket location
server_socket = file:///var/run/kopano/server.sock

# Disable archiving momentarily by setting this to 'no'
archive_enable  =       yes

# Archive messages older than N days
archive_after   =       365

# Stubbing messages requires a multi-server environment
stub_enable     =       no

# Unread messages can be skipped in the stubbing process
stub_unread     =       no

# Only stub messages after N days, 0 for the same as archive_after
stub_after      =       0

# Delete archives messages from the original server. Only archived messages can be deleted.
delete_enable   =       yes

# Also delete unread messages from the original server
delete_unread   =       yes

# Only delete messages after N days, 0 for the same as archive_after
delete_after    =       0

# Purge messages from the archive server(s).
purge_enable    =       no

# Only purge messages after N days, 0 for the same as archive_after
# Default: 2555 (7 years)
purge_after     =       2555

# Specify what action should be taken on archive messages whose primary message
# has been deleted. The normal options are 'store' and 'delete', meaning store the
# archived message in a special 'Deleted' folder or delete the archived messages
# respectively. A third option 'none' skips the entire cleanup_action, and therefore
# effectively turns off archiver cleanup, leaving archived messages as they are.
# Default: store
cleanup_action  =       store

# Specify if items that are cleaned up from the archive are at least the age
# that is specified in the purge_after setting. This is to avoid messages
# being deleted from the archive when they where deleted from the primary
# store by a delete operation.
# Note that setting to yes, will cause a cleanup run to seemingly do nothing.
# A rule of thumb is to set this to the same value as delete_enable. So when
# delete_enable is set to yes, make sure cleanup_follow_purge_after is also
# set to yes.
# Default: no
cleanup_follow_purge_after      =       no

# Specify whether on each archive run an auto-attach run is performed in order
# to match the attached archives to the requested state as specified in LDAP or
# ADS.
# Default: no
enable_auto_attach = yes
# Specify whether an auto attached archive will be granted write permissions
# for the user it's attached to.
# Default: yes
auto_attach_writable = yes

##############################################################
# ARCHIVER LOG SETTINGS

# Logging method (syslog, file)
log_method      =       file

# Loglevel (0(none), 1(crit), 2(err), 3(warn), 4(notice), 5(info), 6(debug))
log_level       =       6

# Logfile for log_method = file, use '-' for stderr
log_file        =       /var/log/kopano/archiver.log

# Log timestamp - prefix each log line with timestamp in 'file' logging mode
log_timestamp   =       1

# Buffer logging in what sized blocks. 0 for line-buffered (syslog-style).
#log_buffer_size = 0

##############################################################
# ARCHIVER SSL LOGIN SETTINGS
#
# Note: server_socket must be set to https://servername:portname/
#       to use this type of login method

# Login to the storage server using this SSL Key
#sslkey_file = /etc/kopano/ssl/archiver.pem

# The password of the SSL Key
#sslkey_pass = replace-with-archiver-cert-password

##############################################################
# ARCHIVER INSTANCE PROTECTION SETTINGS

# Control pid file
# Default: /var/run/kopano/archiver.pid
#pid_file = /var/run/kopano/archiver.pid

##############################################################
# ARCHIVER MYSQL SETTINGS

# MySQL hostname to connect to for database access
mysql_host              = localhost

# MySQL port to connect with (usually 3306)
mysql_port              = 3306

# The user under which we connect with MySQL
mysql_user              = kopano

# The password for the user (leave empty for no password)
mysql_password          = kopano

# Override the default MySQL socket to access mysql locally
# Works only if the mysql_host value is empty or 'localhost'
mysql_socket            =

# Database to connect to
mysql_database          = kopano_archiver

The LDAP attribute of a user has to specify the archiver server. Not sure what happens if it is missing, but if it does not stop, it might just use archiveserver=userserver.

kopanoUserServer: ms1.lh
kopanoUserArchiveServers: ms2.lh

This mean:

There should be 2 seperate kopano servers.
The first one is the primary server and the second one is the archiv server.

In my configuration i only have one server with two databases.

@klipp said in kopano archiver error:

There should be 2 seperate kopano servers.
The first one is the primary server and the second one is the archiv server.

yes, this is also how it is explained in https://documentation.kopano.io/kopano_archiver_manual/

It does not have to be two separate systems. But if you want the archive database to be separate from the main database, you will need to run two kopano-server instances, at different TCP and socket ports naturally. Two or more kopano-server instances mean multiserver, and that requires appropriate LDAP entries for said servers, plus a DNS name. It all can run on the same system, but performance is said to be only won by spreading it out onto different hardware.