Ubuntu 16.04 package dependencies seem to miss specific dependencies (versions)

Hi!

OS: Ubuntu 16.04.3
I tried upgrading kopano-server-packages from 8.4.4.0-0+29.1 to 8.5.4.0-0+9.1 :

apt-get update
apt-get install kopano-server-packages

the upgrade runs fine, but the individual dependencies of packages like kopano-spooler etc are not updated. e.g.:

libkcarchiver0, libkcarchivercore0, libkcinetmapi0, libkcmapi0, libkcutil0

after the upgrade services like kopano-spooler don’t startup anymore, producing errors like:

Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcarchivercore.so.0: version `KC_8.5' not found (required by /usr/sbin/kopano-spooler)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libmapi.so.1: version `KC_8.5' not found (required by /usr/sbin/kopano-spooler)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcmapi.so.0: version `KC_8.5' not found (required by /usr/sbin/kopano-spooler)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcutil.so.0: version `KC_8.5' not found (required by /usr/sbin/kopano-spooler)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcinetmapi.so.0: version `KC_8.5' not found (required by /usr/sbin/kopano-spooler)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcmapi.so.0: version `KC_8.5' not found (required by /usr/lib/libkcarchiver.so.0)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcutil.so.0: version `KC_8.5' not found (required by /usr/lib/libkcarchiver.so.0)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libmapi.so.1: version `KC_8.5' not found (required by /usr/lib/libkcarchiver.so.0)
Mar 07 15:41:54 mail kopano-spooler[6595]: /usr/sbin/kopano-spooler: /usr/lib/libkcarchiver.so.0: version `KC_8.4' not found (required by /usr/lib/libkcarchivercore.so.0)

suspected cause: the specific version dependency is missing:

apt-cache show kopano-spooler

...
Source: kopano
Version: 8.5.4.0-0+9.1
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libkcarchiver0, libkcarchivercore0, libkcinetmapi0, libkcmapi0, libkcutil0, libmapi1, libpython2.7 (>= 2.7), libstdc++6 (>= 5.2), kopano-common (= 8.5.4.0-0+9.1), kopano-client (= 8.5.4.0-0+9.1), python-mapi (= 8.5.4.0-0+9.1)
Filename: ./amd64/kopano-spooler_8.5.4.0-0+9.1_amd64.deb
...

‘libkcarchiver0, libkcarchivercore0, libkcinetmapi0, libkcmapi0, libkcutil0, libmapi1’ above have no version specified that needs to be present, so those packages won’t get updated.

I know i could also do apt-get upgrade to upgrade ALL available updates on a system, but i have systems, where i want to upgrade ONLY kopano & its dependencies specifically.

these problem(missing version numbers in dependencies) exists at least for the following packages:

kopano-backup
kopano-dagent
kopano-gateway
kopano-ical
kopano-monitor
kopano-presence
kopano-search
kopano-server
kopano-spooler
kopano-utils


Details:

kopano-backup
Depends: python-kopano, kopano-common
kopano-dagent
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libicu55 (>= 55.1-1~), libkcarchiver0, libkcarchivercore0, libkcinetmapi0, libkcmapi0, libkcssl0, libkcutil0, libmapi1, libpython2.7 (>= 2.7), libstdc++6 (>= 5.2), kopano-common (= 8.5.4.0-0+9.1), kopano-client (= 8.5.4.0-0+9.1), php7-mapi (= 8.5.4.0-0+9.1), php-cli | php5-cli | php7.0-cli, python-mapi (= 8.5.4.0-0+9.1)
kopano-gateway
Depends: libc6 (>= 2.16), libgcc1 (>= 1:3.0), libicu55 (>= 55.1-1~), libkcinetmapi0, libkcmapi0, libkcssl0, libkcutil0, libmapi1, libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 5.2), kopano-common (= 8.5.4.0-0+9.1), kopano-client (= 8.5.4.0-0+9.1)
kopano-ical
Depends: libc6 (>= 2.16), libgcc1 (>= 1:3.0), libical1a (>= 1.0), libicu55 (>= 55.1-1~), libkcfreebusy0, libkcicalmapi0, libkcmapi0, libkcssl0, libkcutil0, libmapi1, libstdc++6 (>= 5.2), libxml2 (>= 2.7.4), kopano-common (= 8.5.4.0-0+9.1), kopano-client (= 8.5.4.0-0+9.1)
kopano-monitor
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libkcmapi0, libkcutil0, libmapi1, libstdc++6 (>= 5.2), kopano-common (= 8.5.4.0-0+9.1), kopano-client (= 8.5.4.0-0+9.1)
kopano-presence
Depends: kopano-common, python-kopano, python-flask, python-sleekxmpp
kopano-search
Depends: python-kopano, python-xapian, lsb-base, coreutils (>= 5.93), mktemp (>= 1.5), bash (>= 3.0), gawk, w3m, xsltproc, poppler-utils, unzip, file, catdoc, xapian-tools
kopano-server
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libgsoap-kopano-2.8.62, libicu55 (>= 55.1-1~), libkcserver0, libkcsoap0, libkcssl0, libkcutil0, libldap-2.4-2 (>= 2.4.7), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 5.2), kopano-common (= 8.5.4.0-0+9.1), kopano-utils, libtcmalloc-minimal4, libs3-4
kopano-spooler
Depends: libc6 (>= 2.14), libgcc1 (>= 1:3.0), libkcarchiver0, libkcarchivercore0, libkcinetmapi0, libkcmapi0, libkcutil0, libmapi1, libpython2.7 (>= 2.7), libstdc++6 (>= 5.2), kopano-common (= 8.5.4.0-0+9.1), kopano-client (= 8.5.4.0-0+9.1), python-mapi (= 8.5.4.0-0+9.1)
kopano-utils
Depends: libc6 (>= 2.15), libcurl3 (>= 7.16.2), libgcc1 (>= 1:3.0), libkcarchiver0, libkcmapi0, libkcssl0, libkcutil0, libmapi1, libncursesw5 (>= 6), libstdc++6 (>= 5.2), libtinfo5 (>= 6), kopano-client (= 8.5.4.0-0+9.1)

followup: @fbartels do you plan on adding dependency specifics to the packages mentioned above?
e.g. adding to package kopano-spooler that it depends on libkcarchivercore0 (>= x.y.z )

what is the recommended way to upgrade all packages coming from kopano.io, without upgrading ALL other packages on a system?

I’d imagine that package pinning would be the way to achieve this.

If you want any guarantees response times, I’d rather recommend to open a support case. (Links below)

Can you elaborate on how you’d achieve an upgrade of all packages coming from kopano.io via package-pinning?