kopano-dagent error



  • Hello,

    I have installed Kopano 8.5.3.0 on CentOS 6 with qmail.
    kopano-dagent show this error on every incomming mail:

    Wed Feb 28 12:55:05 2018: [18805] [warning] ! Plugins directory '/var/lib/kopano/dagent/plugins' doesn't exists.Plugins not loaded.
    Wed Feb 28 12:55:05 2018: [18805] [error  ] virtual HRESULT M4LMsgServiceAdmin::ConfigureMsgService(const MAPIUID*, ULONG_PTR, ULONG, ULONG, const SPropValue*): MSGServiceEntry failed: logon failed (80040111)
    Wed Feb 28 12:55:05 2018: [18805] [crit   ] CreateProfileTemp(): ConfigureMsgService failed 80040111: logon failed
    Wed Feb 28 12:55:05 2018: [18805] [warning] CreateProfileTemp failed: 80040111: logon failed
    

    The Plugin directory exists:

    [root@server ~]# ls -l /var/lib/kopano/dagent
    insgesamt 4
    drwxr-x--- 2 kopano kopano 4096 21. Feb 17:11 plugins
    


  • Hello @yythoss

    do you have a "run_as_user " and/or “run_as_group” set in your dagent.cfg?
    and second, check the permissions on the directory levels above /var/lib/kopano

    coffee_is_life



  • No, is that necessary?



  • nope,

    my config:

    #run as specific user in LMTP mode.
    #   make sure this user is listed in local_admin_users in your storage server config
    #   or use SSL connections with certificates to login
    run_as_user =
    
    # run as specific group in LMTP mode.
    run_as_group =
    


  • I changed the settings, but the error still exists.

    #run_as_user = kopano
    run_as_user =
    
    # run as specific group in LMTP mode.
    #run_as_group = kopano
    run_as_group =
    


  • do you mean the run_as_user or the permissions?

    check the top levels of /var/lib/kopano



  • I mean the run_as_user setting.
    Here the directory permissions:

    [root@server ~]# ls -l /var/lib/kopano
    insgesamt 20
    drwx------ 2 kopano kopano 4096 10. Feb 13:12 attachments
    drwxr-x--- 2 kopano kopano 4096 21. Feb 17:12 autorespond
    drwxr-x--- 3 kopano kopano 4096 21. Feb 17:11 dagent
    drwxr-x--- 5 kopano kopano 4096 21. Feb 17:11 search
    drwxr-x--- 3 kopano kopano 4096 21. Feb 17:11 spooler
    


  • seems ok…

    what about the kopano-folder itself? - dont think this is the issue cause then other kopano-services would be effected too.
    but better double chekck than search to death

    coffee_is_life



  • I think the kopano folder is ok:

    [root@server ~]# ls -l /var/lib/ | grep kopano
    drwxrwxr-x 7 kopano  kopano  4096 21. Feb 17:12 kopano
    drwxrwx--- 3 root    www     4096 20. Feb 12:50 kopano-webapp
    


  • I see that kopano run dagent and use the right config file:

    [root@server ~]# ps aux|grep dagent
    kopano   27501  0.0  0.1 248708  4156 ?        Sl   17:00   0:00 /usr/sbin/kopano-dagent -d -c /etc/kopano/dagent.cfg
    kopano   27503  0.0  0.0 225064  1896 ?        S    17:00   0:00 /usr/sbin/kopano-dagent -d -c /etc/kopano/dagent.cfg
    root     27801  0.0  0.0 103348   872 pts/1    S+   17:09   0:00 grep dagent
    


  • [root@server]# ps aux|grep dagent
    root     10000  0.0  0.0 256132  5424 ?        Ssl  Feb19   0:17 /usr/sbin/kopano-dagent -l
    root     10009  0.0  0.0 234524  2468 ?        S    Feb19   0:28 /usr/sbin/kopano-dagent -l
    root     31606  0.0  0.0 112680   976 pts/0    S+   07:59   0:00 grep --color=auto dagent
    

    dont know why, but mine is running as root and with option “-l” without setting another user…

    someone from kopano-team got ideas?

    coffee_is_life



  • The option -d run kopano-dagent as deamon and -l option as listener.
    I use qmail and I don’t know which option I need.
    The kopano Installation is a Zarafa upgrade and zarafa-dagent was start with -d option.



  • Hello.

    I think i had the same problems with an old zarafa installation and centos6 but just try to run dagent as root.
    I cant remember the solution but maybe SELinux was the problem.

    cheers Basti



  • I commonly disable SELinux, whenever I have something weird. For testing, you can do this for CentOS 6 by running

    cat  /selinux/enforce
    

    (record the output for switching it on again, and then disable SELinux:)

    echo 0 > /selinux/enforce
    

    The other tool in question is to run strace -p {dagent-processID} and look for the results of the system calls. You might find permission errors and such.



  • After the last update, erverything works fine.