No access rights via Outlook 2010 MAPI

Hello Forum,

after upgrading from 8.4.6.0-9.1 to 8.5.1.0-8.1 i cant acces Calendars via Outlook 2010, connected with Mapi and old Zarafa Client (7.2.4.52167).

Webapp is working, permissions are unchanged and Outlook tells me:
0_1519028888639_05e0ccca-f4cc-428d-9ba4-920c5b2a5af6-grafik.png

even with postmaster rights!

is there a new client, a workaround or another way (except IMAP) to connect to KC?

coffee_is_life

Hi @Coffee_is_life ,

I’ve moved your post to the legacy software, since your problem is more likely caused by office updates, then the kc update.

Hello @fbartels,

i’ve updated kopano friday night, before that everything went fine.
Searched for Microsoft Office Updates, last installed on 12.02.2018.

So i think not.

//EDIT:
Same results on my test system - since its online 24/7 his updates came some days earlier than employees PC:
0_1519035264191_312078cf-523b-4439-8086-39d0ef08f545-grafik.png

coffee_is_life

@coffee_is_life
same issues here, since kopano (NOT OFFICE) updates 8.5.
In the case of Outlook 2010, I was even unable to temporary open the shared Kalender via zarafa-plugin:
0_1519055366030_b7eeb500-016c-4f27-a0dc-6cc47c15e9dc-grafik.png
BUT: after recreating the Outlook-Profile, it works (as bad as) before, but works with all known limitations of the office-Updates

hello @segro,

opening the store temporary is possible without problems, but this is maybe just a workaround for some days.
I created the Profile several times on my test-system and everytime got the same result

coffee_is_life

unfortunately you need a newer Zarafa Client (7.2.6.xxx) to work …

Hello @segro,

i’ve installed 7.2.6, recreated the profile on my testsystem and still getting the sam eerror:

Opening store temporary via Zarafa-Plugin works normally.
Accessing calendars via shared stores doesnt work.
opening public stores works as expected.

0_1519300313891_9d0039a2-b990-4216-b2b5-5b8d671a1078-grafik.png

0_1519300365289_484bf5c3-ea2a-4e6b-8892-b169e2b0bcac-grafik.png

tryed with setting accesrights only to me - not working
tryed to a store everyone can connect (shared to ad-group “domain-users”)

coffee_is_life

Hi there,

Same problem here (in Outlook 2013). It is not related to Windows or Office updates. Something regarding permissions has changed in the kopano-core between version 8.4.6 and 8.5. There is a workaround, adding a shared calendar doesn’t work anymore but you can still do the following: share the entire mailbox and give ‘no permissions’ profile rights on the highest level of the mailbox (only traverse rights) and subsequently read or write permissions on the calendar. If the other party then adds the entire mailbox to Outlook, (not only the calendar) the calendar will become visible again. There are other problems though, the delegate feature doesn’t work properly anymore in Outlook. Accepting meetings requests on behalf of someone throws an error message.

We have reverted the update (you can safely downgrade from 8.5 to 8.4.6), i guess 8.4.6 is the last version that works with Outlook.

Hello @kopiko,

thanks for the nice workaround, can see the calendar now, but even with settings rights from “everyone” and myself to “nothing” or “other” (like nothing but even without permission to list folders) i can see the inbox. - same at your side?

@ kopano-team - is this issue known and maybe fixed in future releases? - otherwise i need to downgrade

coffee_is_life

Not with 8.4.6, if I give someone permissions and without the ‘list folder’ option he is not allowed to browse my mailbox. It wouldn’t surprise me if this is different in 8.5 though…

it is :)

Our development is currently looking into the “not updating of calendars” for the old Zarafa mapi client, but as the mapi client is unsupported and untested in Kopano this did not come up earlier. We are currently expecting to know more on monday.

If you want to be kept updated I would recommend to open a support case.

Hi fbartels, thanks for the update. Cleary, something has changed between versions 8.4.6 - 8.5 regarding permissions. I know Outlook via MAPI is not supported but there are still people using it. We are slowly trying to push the DeskApp client but users generally do not like change…

I will open a ticket!

hello @fbartels,

just created the ticket (KS-40047)

coffee_is_life

any updates here?

Yes, a new release of KC (8.5.4) has been made available yesterday which addresses this issue.

very nice thanks

coffee_is_life

just FYI:

we are using a room called “Besprechungsraum”.
to accept everything in nearly realtime, “kopano-mr-accept” is used in cronjob.

if i call this line now i get following error:

PHP Warning:  include(mapi/mapi.util.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 21
PHP Warning:  include(): Failed opening 'mapi/mapi.util.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 21
PHP Warning:  include(mapi/mapidefs.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 22
PHP Warning:  include(): Failed opening 'mapi/mapidefs.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 22
PHP Warning:  include(mapi/mapicode.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 23
PHP Warning:  include(): Failed opening 'mapi/mapicode.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 23
PHP Warning:  include(mapi/mapitags.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 24
PHP Warning:  include(): Failed opening 'mapi/mapitags.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 24
PHP Warning:  include(mapi/mapiguid.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 25
PHP Warning:  include(): Failed opening 'mapi/mapiguid.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 25
PHP Warning:  include(mapi/class.meetingrequest.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 27
PHP Warning:  include(): Failed opening 'mapi/class.meetingrequest.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 27
PHP Warning:  include(mapi/class.baserecurrence.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 28
PHP Warning:  include(): Failed opening 'mapi/class.baserecurrence.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 28
PHP Warning:  include(mapi/class.recurrence.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 29
PHP Warning:  include(): Failed opening 'mapi/class.recurrence.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 29
PHP Warning:  include(mapi/class.freebusypublish.php): failed to open stream: No such file or directory in /usr/sbin/kopano-mr-accept on line 30
PHP Warning:  include(): Failed opening 'mapi/class.freebusypublish.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /usr/sbin/kopano-mr-accept on line 30
PHP Fatal error:  Call to undefined function forceUTF8() in /usr/sbin/kopano-mr-accept on line 436

the files are located in “/usr/share/kopano/php/mapi/”, all files are created on Feb 14th.

changed my php settings to “include_path=”.:/usr/share/pear:/usr/share/php:/usr/share/kopano/php"
now it can locate the files, but another error came up:

PHP Fatal error:  Call to undefined function mapi_make_scode() in /usr/share/kopano/php/mapi/mapicode.php on line 40

is this fixed in the new version from Feb 28th aswell?

coffee_is_life

Update:

upgraded my testsystem and the MAPI connection from outlook 2010 doesnt work
same for "/usr/sbin/kopano-mr-accept “Besprechungsraum” “/etc/kopano/dagent.cfg”

if i add /usr/share/kopano/php to the include paths, same error:

PHP Fatal error:  Call to undefined function mapi_make_scode() in /usr/share/kopano/php/mapi/mapicode.php on line 40

:(

coffee_is_life

@coffee_is_life said in No access rights via Outlook 2010 MAPI:

upgraded my testsystem and the MAPI connection from outlook 2010 doesnt work

Please contact support