Database or I/O error



  • Hello Kopano-Team,

    we got a bunch of Outlook 2010, accessing Kopano directly via MAPI.

    Some People who accept meeting-request (for their own) are getting Errors:
    “Database or I/O Error”

    On the Server i’m getting following error:

    Tue Feb 13 14:27:26 2018: [error  ] SQL [00082009] Failed: Deadlock found when trying to get lock; try restarting transaction, Query Size: 127, Query: "UPDATE properties SET val_ulong = IF (val_ulong >= 1, val_ulong + -1, 0) WHERE hierarchyid = 62529 AND tag = 13826 AND type = 3"
    Tue Feb 13 14:27:26 2018: [error  ] KDatabase::I_Update() query failed: UPDATE properties SET val_ulong = IF (val_ulong >= 1, val_ulong + -1, 0) WHERE hierarchyid = 62529 AND tag = 13826 AND type = 3: Deadlock found when trying to get lock; try restarting transaction
    Tue Feb 13 14:27:26 2018: [info   ] Error while deleting expanded item list, error code 2147483655
    
    

    is there some sort of script who can fix this (maybe fix herachy script? - dont want to run it unless i know this will help)
    in my opinion this could be some sort of db misconfiguration. here my my.cnf/kopano.cnf under my.d:
    my.cnf

    [mysqld]
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    default-storage-engine=InnoDB
    [mysqld_safe]
    log-error=/var/log/mariadb/mariadb.log
    pid-file=/var/run/mariadb/mariadb.pid
    !includedir /etc/my.cnf.d
    

    kopano.cnf:

    [mysqld]
    datadir=/export/data/mail/db
    innodb_buffer_pool_size = 8192M
    innodb_log_file_size = 512M
    innodb_log_buffer_size = 16M
    max_allowed_packet = 64M
    max_connections = 100
    innodb_file_per_table=1
    long_query_time = 5
    query_cache_size = 64M
    #thread_cache_size = 80 ##//good value= number of kopano-threads + 1 // currently 8 threads
    thread_cache_size = 9
    ### known as "table_cache" in versions 5.1 and earlier (Kopano tables + max mysql connections) * 10, for example (26 + 100 ) * 10 (at max_connection=100 not possible max usable 500 users)
    table_open_cache = 500
    
    # Primer tuning
    #join_buffer_size = 256K  ##edited recommended by kopano set to max (2M) regardless of size of environment)
    join_buffer_size = 2M
    innodb_buffer_pool_instances = 2
    
    
    
    ##NEW recommended by kopano
    sort_buffer_size = 2M
    transaction-isolation = READ-COMMITTED
    
    ## in order to use "enable_sql_procedures = yes" in kopano.cfg we need at least 512K
    thread_stack = 512K
    
    # RHEL6 do no use any query cache size !! kills performance - we got RHEL7 so we are using recommended settings
    query_cache_size = 64M
    query_cache_limit = 2M
    
    ## only in 5.5 or higher   thumb-rule= cores/2 ~  4/2 = 2  
    innodb_write_io_threads = 2
    innodb_read_io_threads = 2
    
    ## in case of remote storage: innodb_flush_method = O_DIRECT    ###OTHERWISE (ours - we are using ISCSI at ESXI) -> innodb_flush_method = O_DSYNC
    innodb_flush_method = O_DSYNC
    

    System: 8 cores, 24GB ram - all other infos are in my signature

    thanks in advance

    coffee_is_life