Newbie Question - Installation



  • I am a moderate Linux user. I am using ClearOS 7 (RH) as my gateway,router,server etc and would like to use Kopano as my mail business system. Could someone please point to me a good resource to install?

    I have been using this, but it does not correspond with the DL packages here.

    Any help would be appreciated.



  • Hi @canerican
    if you don’t want to have much investment with installation and administration I recommend the univention Server.
    Its free after registration
    https://www.univention.com/products/ucs/
    and you have several Kopano apps.
    The server itself creates user with an openldap Server and the admin interface is very easy to use.

    https://www.univention.com/products/univention-app-center/app-catalog/kopano-core/

    Good Luck and best regards
    Andy


  • Kopano

    Hi @canerican ,

    the linked resource uses some urls that are only accessible for Kopano customers with a subscription. When installing you simply have to replace the repo configuration with downloading the archives from download.kopano.io/community and then do a yum localinstall instead of plain yum.



  • Felix,

    Thanks for the localinstall tip

    I tried that, but am getting dependencies problems.

    yum localinstall kopano-server-packages-8.5.81.58-17.1.x86_64.rpm
    
    [root@gateway core-8.5.81.58_0+17-RHEL_7_PHP_56-x86_64]ls -x
    gperftools-2.5-34.5.x86_64.rpm                    gperftools-debuginfo-2.5-34.5.x86_64.rpm
    gperftools-devel-2.5-34.5.x86_64.rpm              gsoap-kopano-debuginfo-2.8.60-1.1.x86_64.rpm
    gsoap-kopano-devel-2.8.60-1.1.x86_64.rpm          gsoap-kopano-doc-2.8.60-1.1.noarch.rpm
    kopano-backup-8.5.81.58-17.1.x86_64.rpm           kopano-bash-completion-8.5.81.58-17.1.noarch.rpm
    kopano-client-8.5.81.58-17.1.x86_64.rpm           kopano-common-8.5.81.58-17.1.x86_64.rpm
    kopano-compat-8.5.81.58-17.1.x86_64.rpm           kopano-contacts-8.5.81.58-17.1.x86_64.rpm
    kopano-dagent-8.5.81.58-17.1.x86_64.rpm           kopano-debuginfo-8.5.81.58-17.1.x86_64.rpm
    kopano-devel-8.5.81.58-17.1.x86_64.rpm            kopano-gateway-8.5.81.58-17.1.x86_64.rpm
    kopano-ical-8.5.81.58-17.1.x86_64.rpm             kopano-lang-8.5.81.58-17.1.x86_64.rpm
    kopano-migration-imap-8.5.81.58-17.1.noarch.rpm   kopano-migration-pst-8.5.81.58-17.1.x86_64.rpm
    kopano-monitor-8.5.81.58-17.1.x86_64.rpm          kopano-presence-8.5.81.58-17.1.x86_64.rpm
    kopano-search-8.5.81.58-17.1.x86_64.rpm           kopano-server-8.5.81.58-17.1.x86_64.rpm
    kopano-server-packages-8.5.81.58-17.1.x86_64.rpm  kopano-spooler-8.5.81.58-17.1.x86_64.rpm
    kopano-utils-8.5.81.58-17.1.x86_64.rpm            libgsoap-kopano-2_8_60-2.8.60-1.1.x86_64.rpm
    libjansson4-2.7-19.3.x86_64.rpm                   libjansson-debuginfo-2.7-19.3.x86_64.rpm
    libjansson-devel-2.7-19.3.x86_64.rpm              libkcarchiver0-8.5.81.58-17.1.x86_64.rpm
    libkcarchivercore0-8.5.81.58-17.1.x86_64.rpm      libkcfreebusy0-8.5.81.58-17.1.x86_64.rpm
    libkcicalmapi0-8.5.81.58-17.1.x86_64.rpm          libkcinetmapi0-8.5.81.58-17.1.x86_64.rpm
    libkcmapi0-8.5.81.58-17.1.x86_64.rpm              libkcserver0-8.5.81.58-17.1.x86_64.rpm
    libkcsoap0-8.5.81.58-17.1.x86_64.rpm              libkcssl0-8.5.81.58-17.1.x86_64.rpm
    libkcsync0-8.5.81.58-17.1.x86_64.rpm              libkcutil0-8.5.81.58-17.1.x86_64.rpm
    libmapi1-8.5.81.58-17.1.x86_64.rpm                libprofiler0-2.5-34.5.x86_64.rpm
    libs3-4-4.1.git257-2.2.x86_64.rpm                 libs3-debuginfo-4.1.git257-2.2.x86_64.rpm
    libs3-devel-4.1.git257-2.2.x86_64.rpm             libs3-tools-4.1.git257-2.2.x86_64.rpm
    libtcmalloc4-2.5-34.5.x86_64.rpm                  libtidy5-5.1.9-1.3.x86_64.rpm
    libunwind-1.1-98.3.x86_64.rpm                     libunwind-debuginfo-1.1-98.3.x86_64.rpm
    libunwind-devel-1.1-98.3.x86_64.rpm               libvmime-devel-0.9.2-13.1.x86_64.rpm
    libvmime-kopano1-0.9.2-13.1.x86_64.rpm            libvmime_kopano-debuginfo-0.9.2-13.1.x86_64.rpm
    libxapian22-1.2.21-1.4.x86_64.rpm                 libxapian-devel-1.2.21-1.4.x86_64.rpm
    php-mapi-8.5.81.58-17.1.x86_64.rpm                php-mapi-webapp-0-4.1.noarch.rpm
    php-xapian-1.2.21-5.4.x86_64.rpm                  python-Flask-0.10.1-2.3.x86_64.rpm
    python-Flask-debuginfo-0.10.1-2.3.x86_64.rpm      python-itsdangerous-0.24-1.3.noarch.rpm
    python-Jinja2-2.7.3-1.3.noarch.rpm                python-Jinja2-emacs-2.7.3-1.3.noarch.rpm
    python-Jinja2-vim-2.7.3-1.3.noarch.rpm            python-kopano-8.5.81.58-17.1.x86_64.rpm
    python-mapi-8.5.81.58-17.1.x86_64.rpm             python-MarkupSafe-0.23-1.3.x86_64.rpm
    python-MarkupSafe-debuginfo-0.23-1.3.x86_64.rpm   python-sleekxmpp-1.1.11-1.4.noarch.rpm
    python-tlslite-0.4.6-1.3.noarch.rpm               python-tlslite-doc-0.4.6-1.3.noarch.rpm
    python-Werkzeug-0.10.4-1.3.noarch.rpm             python-xapian-1.2.21-5.4.x86_64.rpm
    tidy-html5-5.1.9-1.3.x86_64.rpm                   tidy-html5-debuginfo-5.1.9-1.3.x86_64.rpm
    tidy-html5-devel-5.1.9-1.3.x86_64.rpm             xapian-bindings-debuginfo-1.2.21-5.4.x86_64.rpm
    xapian-core-1.2.21-1.4.x86_64.rpm                 xapian-core-debuginfo-1.2.21-1.4.x86_64.rpm
    xapian-core-doc-1.2.21-1.4.x86_64.rpm             xapian-core-examples-1.2.21-1.4.x86_64.rpm
    

  • Kopano

    Hi @canerican ,

    it seems the text you pasted does not include your error message. Apart from that you download seems to be quite old already, I would recommend to grab the latest archive and try again.



  • Thanks Felix,

    I downloaded the latest core (core-8.5.81.58_0+17-RHEL_7_PHP_56-x86_64.tar.gz)

    Here are the results:

    --> Processing Dependency: kopano-dagent = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-gateway = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-ical = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-monitor = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-presence = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-search = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-server = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-spooler = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Processing Dependency: kopano-utils = 8.5.81.58 for package: kopano-server-packages-8.5.81.58-17.1.x86_64
    --> Finished Dependency Resolution
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-search = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-gateway = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-ical = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-utils = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-backup = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-dagent = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-server = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-monitor = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-presence = 8.5.81.58
    Error: Package: kopano-server-packages-8.5.81.58-17.1.x86_64 (/kopano-server-packages-8.5.81.58-17.1.x86_64)
               Requires: kopano-spooler = 8.5.81.58
     You could try using --skip-broken to work around the problem
    

  • Kopano

    @canerican the latest one is core-8.5.81.197_0