Sync problem with default Android application

Hello,

I have problem with syncing emails in default application (Gmail) in Android 6 and Android 7 (but for example in Nine or Mailwise all works goodly).

I don’t see all emails, or I see empty inbox, or my gmail is freezing up or it’s getting to loop during synchronization, or it freeze after switch from sent folder to inbox folder, etc.

I think it’s problem with default folders (I set up it in imap.conf.php as you can see below, but without success).

My configuration is:
z-push with backendcombined with backends imap, carddav, caldav
centos 6.5, dovecot 2.2.x (maildir), apache 2.4.x, php 5.6.x (I don’t use php-fpm)

This is structure of my typical mailbox:
drwx------ 5 test6 uzivatele 4096 Jun 28 14:51 Archive
drwxr-xr-x 2 test6 uzivatele 4096 Jun 28 15:05 cur
-rw-r–r-- 1 test6 uzivatele 0 Jun 28 14:58 dovecot-acl-list
-rw-r–r-- 1 test6 uzivatele 2464 Jun 29 15:09 dovecot.index.cache
-rw-r–r-- 1 test6 uzivatele 1988 Jun 28 15:05 dovecot.index.log
-rw-r–r-- 1 test6 uzivatele 154 Jun 28 15:04 dovecot-uidlist
-rw-r–r-- 1 test6 uzivatele 8 Jun 28 15:00 dovecot-uidvalidity
-r–r--r-- 1 test6 uzivatele 0 Jun 28 14:58 dovecot-uidvalidity.5953a7fb
drwx------ 5 test6 uzivatele 4096 Jun 28 14:50 Drafts
drwx------ 5 test6 uzivatele 4096 Jun 28 14:50 INBOX
drwxr-xr-x 2 test6 uzivatele 4096 Jun 28 15:04 new
drwx------ 5 test6 uzivatele 4096 Jun 28 14:50 saved-messages
drwx------ 5 test6 uzivatele 4096 Jun 29 14:27 Sent
drwx------ 5 test6 uzivatele 4096 Jun 28 14:50 sent-mail
drwx------ 5 test6 uzivatele 4096 Jun 28 14:50 Spam
drwxr-xr-x 2 test6 uzivatele 4096 Jun 28 15:04 tmp
drwx------ 5 test6 uzivatele 4096 Jun 28 14:50 Trash

This is my imap.conf.php:
define(‘IMAP_FOLDER_INBOX’, ‘INBOX’);
// Sent folder name (case doesn’t matter)
define(‘IMAP_FOLDER_SENT’, ‘Sent’);

// Draft folder name (case doesn’t matter)
define(‘IMAP_FOLDER_DRAFT’, ‘Drafts’);

// Trash folder name (case doesn’t matter)
define(‘IMAP_FOLDER_TRASH’, ‘Trash’);

// Spam folder name (case doesn’t matter). Only showed as special by iOS devices
define(‘IMAP_FOLDER_SPAM’, ‘Spam’);

// Archive folder name (case doesn’t matter). Only showed as special by iOS devices
define(‘IMAP_FOLDER_ARCHIVE’, ‘Archive’);

Here is my wbxml.log https://pastebin.com/TFHKaBRj

Please do you have any idea?

Thank you very much,
Lukas

I think only problem is with settings of IMAP_FOLDER_INBOX. Because now I always see new email only for few seconds and then it is disappearing. I tried set this value to “inbox” or “cur” or leave it empty, but without success. So I don’t know how to set it for this configuration of maildir

Lukas

I know I’ve seen similar before, where emails would appear, flash then disappear… sort of looping…

However, looking back in your logs:

29/06/2017 15:53:31 [23493] [DEBUG] [test6] BackendCalDAV->Logon(): User 'test6' is authenticated on CalDAV 'http://groupware.xxx.cz:80/caldav.php/test6/'
29/06/2017 15:53:31 [23493] [DEBUG] [test6] BackendCardDAV->Logon(): User 'test6' is authenticated on 'http://groupware.xxx.cz:80/caldav.php/test6/'

It looks like you’re using the same url for carddav and caldav?? I’m not sure if that could be affecting things, but I had a massive pain trying to get caldav working when the android gmail client introduced supported for “Tasks” I think, around that time, I saw a similar problem to you…

Not seeing anything else out of the ordinary… though I will say you’ve folder duplications (Sent vs sent-mail, saved-messages versus Drafts)

Hello,

thank you for reply.

It’s URL for logon, it’s same. But URL for resources is different, for example http://groupware.xxx.cz:80/caldav.php/test6/calendar, http://groupware.xxx.cz:80/caldav.php/test6/addresses, etc. I think it’s OK.

Duplicate folders are from another emails clients, their removing doesn’t help.

I alsou thought about Tasks, I tried turn off, but it also doesn’t help me:(

>I know I’ve seen similar before, where emails would appear, flash then disappear… sort of looping…*
Yes, I had exactly same problem. When I set IMAP folders as can you see above, so I have “only” problem, that I don’t see all emails in INBOX, or they are dissappearing, etc. I think that I should set IMAP_FOLDER_INBOX to empty value in my Maildir configuration, but it causes loop

Lukas

Has anyone found a solution to this problem? My inbox mail also disappears in the way described by Lukas.

Z-Push works perfectly with Outlook 2013, the problem only occurs in default mail app in Android 4.4.4 and Android 7.2.1.

I can post wbxml logs as needed.

Versions:
Z-Push 2.4.1
Dovecot 2.2.22

Log in to reply

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.