Install Kopano Core on Ubuntu 16.04 error -



  • Hello,

    i have a problem with the installation of latest kopano core 8.4.0 on my ubuntu 16.04.

    For information, i try a complete reinstall of ubuntu 16.04, but this not solved the problem.

    On the system is only ubuntu 16.04 with plesk onyx 17.5.

    I download the latest core from kopano website with wget in my temp folder.
    I extract this with tar xvfz without problems.

    But after i use the command dpkg - i *.deb, i think the installation is not ok.
    I try to get missing packages with apt-get install -f but this not solved the problem.

    here are my error:

    root@xxxx:/tmp/core-8.4.0~792_149.1-Debian_8.0-amd64# dpkg -i *.deb
    (Reading database ... 160086 files and directories currently installed.)
    Preparing to unpack gsoap-kopano-dbg_2.8.43-3.1_amd64.deb ...
    Unpacking gsoap-kopano-dbg (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack gsoap-kopano-dev_2.8.43-3.1_amd64.deb ...
    Unpacking gsoap-kopano-dev (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack gsoap-kopano-doc_2.8.43-3.1_all.deb ...
    Unpacking gsoap-kopano-doc (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack gsoap-kopano_2.8.43-3.1_amd64.deb ...
    Unpacking gsoap-kopano (2.8.43-3.1) over (2.8.43-3.1) ...
    Replaced by files in installed package gsoap-kopano-dev (2.8.43-3.1) ...
    Selecting previously unselected package kopano-backup.
    Preparing to unpack kopano-backup_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-backup (8.4.0~792-149.1) ...
    Preparing to unpack kopano-bash-completion_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-bash-completion (8.4.0~792-149.1) over (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-client.
    Preparing to unpack kopano-client_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-client (8.4.0~792-149.1) ...
    Preparing to unpack kopano-common_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-common (8.4.0~792-149.1) over (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-contacts.
    Preparing to unpack kopano-contacts_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-contacts (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-dagent.
    Preparing to unpack kopano-dagent_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-dagent (8.4.0~792-149.1) ...
    Preparing to unpack kopano-dbg_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-dbg (8.4.0~792-149.1) over (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-dev.
    Preparing to unpack kopano-dev_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-dev (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-gateway.
    Preparing to unpack kopano-gateway_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-gateway (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-ical.
    Preparing to unpack kopano-ical_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-ical (8.4.0~792-149.1) ...
    Preparing to unpack kopano-lang_8.4.0~792-149.1_all.deb ...
    Unpacking kopano-lang (8.4.0~792-149.1) over (8.4.0~792-149.1) ...
    Preparing to unpack kopano-migration-imap_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-migration-imap (8.4.0~792-149.1) over (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-migration-pst.
    Preparing to unpack kopano-migration-pst_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-migration-pst (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-monitor.
    Preparing to unpack kopano-monitor_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-monitor (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-presence.
    Preparing to unpack kopano-presence_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-presence (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-search.
    Preparing to unpack kopano-search_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-search (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-server-packages.
    Preparing to unpack kopano-server-packages_8.4.0~792-149.1_all.deb ...
    Unpacking kopano-server-packages (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-server.
    Preparing to unpack kopano-server_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-server (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-spooler.
    Preparing to unpack kopano-spooler_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-spooler (8.4.0~792-149.1) ...
    Selecting previously unselected package kopano-utils.
    Preparing to unpack kopano-utils_8.4.0~792-149.1_amd64.deb ...
    Unpacking kopano-utils (8.4.0~792-149.1) ...
    Preparing to unpack libgsoap-kopano-2-8-43_2.8.43-3.1_amd64.deb ...
    Unpacking libgsoap-kopano-2-8-43 (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack libgsoap-kopano-dbg_2.8.43-3.1_amd64.deb ...
    Unpacking libgsoap-kopano-dbg (2.8.43-3.1) over (2.8.43-3.1) ...
    dpkg: warning: downgrading libjansson-dbg:amd64 from 2.7-3 to 2.7-1
    Preparing to unpack libjansson-dbg_2.7-1_amd64.deb ...
    Unpacking libjansson-dbg:amd64 (2.7-1) over (2.7-3) ...
    dpkg: warning: downgrading libjansson-dev:amd64 from 2.7-3 to 2.7-1
    Preparing to unpack libjansson-dev_2.7-1_amd64.deb ...
    Unpacking libjansson-dev:amd64 (2.7-1) over (2.7-3) ...
    dpkg: warning: downgrading libjansson-doc from 2.7-3 to 2.7-1
    Preparing to unpack libjansson-doc_2.7-1_all.deb ...
    Unpacking libjansson-doc (2.7-1) over (2.7-3) ...
    dpkg: warning: downgrading libjansson4:amd64 from 2.7-3 to 2.7-1
    Preparing to unpack libjansson4_2.7-1_amd64.deb ...
    Unpacking libjansson4:amd64 (2.7-1) over (2.7-3) ...
    Selecting previously unselected package libkcarchiver0.
    Preparing to unpack libkcarchiver0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcarchiver0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcarchivercore0.
    Preparing to unpack libkcarchivercore0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcarchivercore0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcfreebusy0.
    Preparing to unpack libkcfreebusy0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcfreebusy0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkchl0.
    Preparing to unpack libkchl0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkchl0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcicalmapi0.
    Preparing to unpack libkcicalmapi0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcicalmapi0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcinetmapi0.
    Preparing to unpack libkcinetmapi0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcinetmapi0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcmapi0.
    Preparing to unpack libkcmapi0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcmapi0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcpyconv0.
    Preparing to unpack libkcpyconv0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcpyconv0 (8.4.0~792-149.1) ...
    Preparing to unpack libkcpydirector0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcpydirector0 (8.4.0~792-149.1) over (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcserver0.
    Preparing to unpack libkcserver0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcserver0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcsoap0.
    Preparing to unpack libkcsoap0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcsoap0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcssl0.
    Preparing to unpack libkcssl0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcssl0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcsync0.
    Preparing to unpack libkcsync0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcsync0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libkcutil0.
    Preparing to unpack libkcutil0_8.4.0~792-149.1_amd64.deb ...
    Unpacking libkcutil0 (8.4.0~792-149.1) ...
    Selecting previously unselected package libmapi1.
    Preparing to unpack libmapi1_8.4.0~792-149.1_amd64.deb ...
    Unpacking libmapi1 (8.4.0~792-149.1) ...
    Preparing to unpack libs3-3_3.0~git226-5.1_amd64.deb ...
    Unpacking libs3-3 (3.0~git226-5.1) over (3.0~git226-5.1) ...
    Preparing to unpack libs3-dev_3.0~git226-5.1_amd64.deb ...
    Unpacking libs3-dev (3.0~git226-5.1) over (3.0~git226-5.1) ...
    Preparing to unpack libtidy5_5.1.9-1.1_amd64.deb ...
    Unpacking libtidy5 (5.1.9-1.1) over (5.1.9-1.1) ...
    Preparing to unpack libvmime-kopano-dev_0.9.2-9.1_amd64.deb ...
    Unpacking libvmime-kopano-dev (0.9.2-9.1) over (0.9.2-9.1) ...
    Preparing to unpack libvmime-kopano1_0.9.2-9.1_amd64.deb ...
    Unpacking libvmime-kopano1 (0.9.2-9.1) over (0.9.2-9.1) ...
    Selecting previously unselected package php5-mapi.
    Preparing to unpack php5-mapi_8.4.0~792-149.1_amd64.deb ...
    Unpacking php5-mapi (8.4.0~792-149.1) ...
    Selecting previously unselected package python-kopano.
    Preparing to unpack python-kopano_8.4.0~792-149.1_all.deb ...
    Unpacking python-kopano (8.4.0~792-149.1) ...
    Selecting previously unselected package python-mapi.
    Preparing to unpack python-mapi_8.4.0~792-149.1_amd64.deb ...
    Unpacking python-mapi (8.4.0~792-149.1) ...
    Preparing to unpack tidy-html5-dev_5.1.9-1.1_amd64.deb ...
    Unpacking tidy-html5-dev (5.1.9-1.1) ...
    dpkg: error processing archive tidy-html5-dev_5.1.9-1.1_amd64.deb (--install):
     trying to overwrite '/usr/lib/libtidy.so', which is also in package libtidy-0.99-0 20091223cvs-1.5
    Preparing to unpack tidy-html5_5.1.9-1.1_amd64.deb ...
    Unpacking tidy-html5 (5.1.9-1.1) over (5.1.9-1.1) ...
    Setting up gsoap-kopano-doc (2.8.43-3.1) ...
    Setting up kopano-bash-completion (8.4.0~792-149.1) ...
    Setting up kopano-common (8.4.0~792-149.1) ...
    dpkg: dependency problems prevent configuration of kopano-dagent:
     kopano-dagent depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     kopano-dagent depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package kopano-dagent (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-dbg (8.4.0~792-149.1) ...
    dpkg: dependency problems prevent configuration of kopano-dev:
     kopano-dev depends on libicu-dev; however:
      Package libicu-dev is not installed.
    
    dpkg: error processing package kopano-dev (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-gateway:
     kopano-gateway depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package kopano-gateway (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-ical:
     kopano-ical depends on libical1a (>= 1.0); however:
      Package libical1a is not installed.
     kopano-ical depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package kopano-ical (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-lang (8.4.0~792-149.1) ...
    Setting up kopano-migration-imap (8.4.0~792-149.1) ...
    dpkg: dependency problems prevent configuration of kopano-presence:
     kopano-presence depends on python-flask; however:
      Package python-flask is not installed.
     kopano-presence depends on python-sleekxmpp; however:
      Package python-sleekxmpp is not installed.
    
    dpkg: error processing package kopano-presence (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-search:
     kopano-search depends on python-xapian; however:
      Package python-xapian is not installed.
     kopano-search depends on catdoc; however:
      Package catdoc is not installed.
    
    dpkg: error processing package kopano-search (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-server-packages:
     kopano-server-packages depends on kopano-dagent (= 8.4.0~792-149.1); however:
      Package kopano-dagent is not configured yet.
     kopano-server-packages depends on kopano-gateway (= 8.4.0~792-149.1); however:
      Package kopano-gateway is not configured yet.
     kopano-server-packages depends on kopano-ical (= 8.4.0~792-149.1); however:
      Package kopano-ical is not configured yet.
     kopano-server-packages depends on kopano-presence (= 8.4.0~792-149.1); however:
      Package kopano-presence is not configured yet.
     kopano-server-packages depends on kopano-search (= 8.4.0~792-149.1); however:
      Package kopano-search is not configured yet.
    
    dpkg: error processing package kopano-server-packages (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-server:
     kopano-server depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     kopano-server depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
     kopano-server depends on libtcmalloc-minimal4; however:
      Package libtcmalloc-minimal4 is not installed.
    
    dpkg: error processing package kopano-server (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-spooler:
     kopano-spooler depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     kopano-spooler depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package kopano-spooler (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-utils:
     kopano-utils depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package kopano-utils (--install):
     dependency problems - leaving unconfigured
    Setting up libgsoap-kopano-2-8-43 (2.8.43-3.1) ...
    Setting up libgsoap-kopano-dbg (2.8.43-3.1) ...
    dpkg: dependency problems prevent configuration of libjansson-doc:
     libjansson-doc depends on libjs-backbone; however:
      Package libjs-backbone is not installed.
    
    dpkg: error processing package libjansson-doc (--install):
     dependency problems - leaving unconfigured
    Setting up libjansson4:amd64 (2.7-1) ...
    dpkg: dependency problems prevent configuration of libkcarchivercore0:
     libkcarchivercore0 depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package libkcarchivercore0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcicalmapi0:
     libkcicalmapi0 depends on libical1a (>= 1.0); however:
      Package libical1a is not installed.
    
    dpkg: error processing package libkcicalmapi0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcinetmapi0:
     libkcinetmapi0 depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
    
    dpkg: error processing package libkcinetmapi0 (--install):
     dependency problems - leaving unconfigured
    Setting up libkcpydirector0 (8.4.0~792-149.1) ...
    dpkg: dependency problems prevent configuration of libkcserver0:
     libkcserver0 depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     libkcserver0 depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package libkcserver0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcutil0:
     libkcutil0 depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package libkcutil0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libmapi1:
     libmapi1 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libmapi1 (--install):
     dependency problems - leaving unconfigured
    Setting up libs3-3 (3.0~git226-5.1) ...
    Setting up libs3-dev (3.0~git226-5.1) ...
    Setting up libtidy5 (5.1.9-1.1) ...
    Setting up libvmime-kopano1 (0.9.2-9.1) ...
    dpkg: dependency problems prevent configuration of php5-mapi:
     php5-mapi depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
     php5-mapi depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
     php5-mapi depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     php5-mapi depends on libmapi1; however:
      Package libmapi1 is not configured yet.
     php5-mapi depends on phpapi-20131226; however:
      Package phpapi-20131226 is not installed.
    
    dpkg: error processing package php5-mapi (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-kopano:
     python-kopano depends on python-dateutil; however:
      Package python-dateutil is not installed.
    
    dpkg: error processing package python-kopano (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-mapi:
     python-mapi depends on libical1a (>= 1.0); however:
      Package libical1a is not installed.
     python-mapi depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
     python-mapi depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
     python-mapi depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     python-mapi depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package python-mapi (--install):
     dependency problems - leaving unconfigured
    Setting up tidy-html5 (5.1.9-1.1) ...
    Setting up gsoap-kopano-dev (2.8.43-3.1) ...
    Setting up gsoap-kopano (2.8.43-3.1) ...
    dpkg: dependency problems prevent configuration of kopano-backup:
     kopano-backup depends on python-kopano; however:
      Package python-kopano is not configured yet.
    
    dpkg: error processing package kopano-backup (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-client:
     kopano-client depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     kopano-client depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package kopano-client (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-contacts:
     kopano-contacts depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     kopano-contacts depends on libmapi1; however:
      Package libmapi1 is not configured yet.
     kopano-contacts depends on kopano-client (= 8.4.0~792-149.1); however:
      Package kopano-client is not configured yet.
    
    dpkg: error processing package kopano-contacts (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-migration-pst:
     kopano-migration-pst depends on python-kopano; however:
      Package python-kopano is not configured yet.
    
    dpkg: error processing package kopano-migration-pst (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-monitor:
     kopano-monitor depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     kopano-monitor depends on libmapi1; however:
      Package libmapi1 is not configured yet.
     kopano-monitor depends on kopano-client (= 8.4.0~792-149.1); however:
      Package kopano-client is not configured yet.
    
    dpkg: error processing package kopano-monitor (--install):
     dependency problems - leaving unconfigured
    Setting up libjansson-dbg:amd64 (2.7-1) ...
    Setting up libjansson-dev:amd64 (2.7-1) ...
    dpkg: dependency problems prevent configuration of libkcarchiver0:
     libkcarchiver0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     libkcarchiver0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcarchiver0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcfreebusy0:
     libkcfreebusy0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     libkcfreebusy0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcfreebusy0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkchl0:
     libkchl0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkchl0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcmapi0:
     libkcmapi0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libkcmapi0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcpyconv0:
     libkcpyconv0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcpyconv0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcsoap0:
     libkcsoap0 depends on libkcmapi0; however:
      Package libkcmapi0 is not configured yet.
     libkcsoap0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libkcsoap0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcssl0:
     libkcssl0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libkcssl0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcsync0:
     libkcsync0 depends on libkcmapi0; however:
      Package libkcmapi0 is not configured yet.
     libkcsync0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcsync0 (--install):
     dependency problems - leaving unconfigured
    Setting up libvmime-kopano-dev (0.9.2-9.1) ...
    Setting up gsoap-kopano-dbg (2.8.43-3.1) ...
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for systemd (229-4ubuntu17) ...
    Processing triggers for libc-bin (2.23-0ubuntu7) ...
    Errors were encountered while processing:
     tidy-html5-dev_5.1.9-1.1_amd64.deb
     kopano-dagent
     kopano-dev
     kopano-gateway
     kopano-ical
     kopano-presence
     kopano-search
     kopano-server-packages
     kopano-server
     kopano-spooler
     kopano-utils
     libjansson-doc
     libkcarchivercore0
     libkcicalmapi0
     libkcinetmapi0
     libkcserver0
     libkcutil0
     libmapi1
     php5-mapi
     python-kopano
     python-mapi
     kopano-backup
     kopano-client
     kopano-contacts
     kopano-migration-pst
     kopano-monitor
     libkcarchiver0
     libkcfreebusy0
     libkchl0
     libkcmapi0
     libkcpyconv0
     libkcsoap0
     libkcssl0
     libkcsync0
    


  • should be apt-get -f install because options come first.



  • I try both.
    apt-get install -f before dpkg -i *.deb (no new package found)
    and apt-get install -f after installation. (packages found and installed, but kopano is not ok)



  • This post is deleted!

  • Kopano

    @nils50122 said in Install Kopano Core on Ubuntu 16.04 error -:

    (packages found and installed, but kopano is not ok)

    your above output very much looks like the output after dpkg -i. What kind of error do you get after apt-get -f install? what kind of errors are the kopano components still throwing?

    Actually I would not recommend to install all of the packages, since the archive also contains debug packages, which you don’t need for day to day usage and also some build dependencies that are otherwise not required for operation at all.



  • @fbartels said in Install Kopano Core on Ubuntu 16.04 error -

    your above output very much looks like the output after dpkg -i. What kind of error do you get after apt-get -f install? what kind of errors are the kopano components still throwing?

    here is the error outpout after apt-get -f install and next dpkg -i *.deb:

    root@xxxxx:/tmp/core-8.4.0~792_150.1-Debian_8.0-amd64# apt-get -f install
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Correcting dependencies... Done
    The following additional packages will be installed:
      libjansson-doc
    The following packages will be REMOVED:
      kopano-backup kopano-client kopano-contacts kopano-dagent kopano-dev kopano-gateway
      kopano-ical kopano-migration-pst kopano-monitor kopano-presence kopano-search
      kopano-server kopano-server-packages kopano-spooler kopano-utils libkcarchiver0
      libkcarchivercore0 libkcfreebusy0 libkchl0 libkcicalmapi0 libkcinetmapi0 libkcmapi0
      libkcpyconv0 libkcserver0 libkcsoap0 libkcssl0 libkcsync0 libkcutil0 libmapi1 php5-mapi
      python-kopano python-mapi
    The following packages will be upgraded:
      libjansson-doc
    1 upgraded, 0 newly installed, 32 to remove and 3 not upgraded.
    33 not fully installed or removed.
    Need to get 0 B/71.5 kB of archives.
    After this operation, 14.7 MB disk space will be freed.
    Do you want to continue? [Y/n] y
    N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
    (Reading database ... 160616 files and directories currently installed.)
    Removing kopano-server-packages (8.4.0~792-150.1) ...
    Removing kopano-backup (8.4.0~792-150.1) ...
    Removing kopano-server (8.4.0~792-150.1) ...
    Removing kopano-utils (8.4.0~792-150.1) ...
    Removing kopano-monitor (8.4.0~792-150.1) ...
    Removing kopano-dagent (8.4.0~792-150.1) ...
    Removing php5-mapi (8.4.0~792-150.1) ...
    Removing kopano-contacts (8.4.0~792-150.1) ...
    Removing kopano-dev (8.4.0~792-150.1) ...
    Removing kopano-gateway (8.4.0~792-150.1) ...
    Removing kopano-ical (8.4.0~792-150.1) ...
    Removing kopano-migration-pst (8.4.0~792-150.1) ...
    Removing kopano-presence (8.4.0~792-150.1) ...
    Removing kopano-search (8.4.0~792-150.1) ...
    Removing kopano-spooler (8.4.0~792-150.1) ...
    Removing libkcarchivercore0 (8.4.0~792-150.1) ...
    Removing libkcarchiver0 (8.4.0~792-150.1) ...
    Removing python-kopano (8.4.0~792-150.1) ...
    Removing python-mapi (8.4.0~792-150.1) ...
    Removing libkcinetmapi0 (8.4.0~792-150.1) ...
    Removing libkcicalmapi0 (8.4.0~792-150.1) ...
    Removing libkchl0 (8.4.0~792-150.1) ...
    Removing libkcserver0 (8.4.0~792-150.1) ...
    Removing libkcpyconv0 (8.4.0~792-150.1) ...
    Removing libkcsync0 (8.4.0~792-150.1) ...
    Removing libkcfreebusy0 (8.4.0~792-150.1) ...
    Removing libmapi1 (8.4.0~792-150.1) ...
    Removing kopano-client (8.4.0~792-150.1) ...
    Removing libkcsoap0 (8.4.0~792-150.1) ...
    Removing libkcmapi0 (8.4.0~792-150.1) ...
    Removing libkcssl0 (8.4.0~792-150.1) ...
    Removing libkcutil0 (8.4.0~792-150.1) ...
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for libc-bin (2.23-0ubuntu7) ...
    (Reading database ... 160094 files and directories currently installed.)
    Preparing to unpack .../libjansson-doc_2.7-3_all.deb ...
    Unpacking libjansson-doc (2.7-3) over (2.7-1) ...
    Setting up libjansson-doc (2.7-3) ...
    N: Ignoring file 'plesk.list.ai_back' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
    root@xxxxx:/tmp/core-8.4.0~792_150.1-Debian_8.0-amd64# dpkg -i *.deb
    (Reading database ... 160089 files and directories currently installed.)
    Preparing to unpack gsoap-kopano-dbg_2.8.43-3.1_amd64.deb ...
    Unpacking gsoap-kopano-dbg (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack gsoap-kopano-dev_2.8.43-3.1_amd64.deb ...
    Unpacking gsoap-kopano-dev (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack gsoap-kopano-doc_2.8.43-3.1_all.deb ...
    Unpacking gsoap-kopano-doc (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack gsoap-kopano_2.8.43-3.1_amd64.deb ...
    Unpacking gsoap-kopano (2.8.43-3.1) over (2.8.43-3.1) ...
    Replaced by files in installed package gsoap-kopano-dev (2.8.43-3.1) ...
    Selecting previously unselected package kopano-backup.
    Preparing to unpack kopano-backup_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-backup (8.4.0~792-150.1) ...
    Preparing to unpack kopano-bash-completion_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-bash-completion (8.4.0~792-150.1) over (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-client.
    Preparing to unpack kopano-client_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-client (8.4.0~792-150.1) ...
    Preparing to unpack kopano-common_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-common (8.4.0~792-150.1) over (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-contacts.
    Preparing to unpack kopano-contacts_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-contacts (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-dagent.
    Preparing to unpack kopano-dagent_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-dagent (8.4.0~792-150.1) ...
    Preparing to unpack kopano-dbg_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-dbg (8.4.0~792-150.1) over (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-dev.
    Preparing to unpack kopano-dev_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-dev (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-gateway.
    Preparing to unpack kopano-gateway_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-gateway (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-ical.
    Preparing to unpack kopano-ical_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-ical (8.4.0~792-150.1) ...
    Preparing to unpack kopano-lang_8.4.0~792-150.1_all.deb ...
    Unpacking kopano-lang (8.4.0~792-150.1) over (8.4.0~792-150.1) ...
    Preparing to unpack kopano-migration-imap_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-migration-imap (8.4.0~792-150.1) over (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-migration-pst.
    Preparing to unpack kopano-migration-pst_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-migration-pst (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-monitor.
    Preparing to unpack kopano-monitor_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-monitor (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-presence.
    Preparing to unpack kopano-presence_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-presence (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-search.
    Preparing to unpack kopano-search_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-search (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-server-packages.
    Preparing to unpack kopano-server-packages_8.4.0~792-150.1_all.deb ...
    Unpacking kopano-server-packages (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-server.
    Preparing to unpack kopano-server_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-server (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-spooler.
    Preparing to unpack kopano-spooler_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-spooler (8.4.0~792-150.1) ...
    Selecting previously unselected package kopano-utils.
    Preparing to unpack kopano-utils_8.4.0~792-150.1_amd64.deb ...
    Unpacking kopano-utils (8.4.0~792-150.1) ...
    Preparing to unpack libgsoap-kopano-2-8-43_2.8.43-3.1_amd64.deb ...
    Unpacking libgsoap-kopano-2-8-43 (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack libgsoap-kopano-dbg_2.8.43-3.1_amd64.deb ...
    Unpacking libgsoap-kopano-dbg (2.8.43-3.1) over (2.8.43-3.1) ...
    Preparing to unpack libjansson-dbg_2.7-1_amd64.deb ...
    Unpacking libjansson-dbg:amd64 (2.7-1) over (2.7-1) ...
    Preparing to unpack libjansson-dev_2.7-1_amd64.deb ...
    Unpacking libjansson-dev:amd64 (2.7-1) over (2.7-1) ...
    dpkg: warning: downgrading libjansson-doc from 2.7-3 to 2.7-1
    Preparing to unpack libjansson-doc_2.7-1_all.deb ...
    Unpacking libjansson-doc (2.7-1) over (2.7-3) ...
    Preparing to unpack libjansson4_2.7-1_amd64.deb ...
    Unpacking libjansson4:amd64 (2.7-1) over (2.7-1) ...
    Selecting previously unselected package libkcarchiver0.
    Preparing to unpack libkcarchiver0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcarchiver0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcarchivercore0.
    Preparing to unpack libkcarchivercore0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcarchivercore0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcfreebusy0.
    Preparing to unpack libkcfreebusy0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcfreebusy0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkchl0.
    Preparing to unpack libkchl0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkchl0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcicalmapi0.
    Preparing to unpack libkcicalmapi0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcicalmapi0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcinetmapi0.
    Preparing to unpack libkcinetmapi0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcinetmapi0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcmapi0.
    Preparing to unpack libkcmapi0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcmapi0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcpyconv0.
    Preparing to unpack libkcpyconv0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcpyconv0 (8.4.0~792-150.1) ...
    Preparing to unpack libkcpydirector0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcpydirector0 (8.4.0~792-150.1) over (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcserver0.
    Preparing to unpack libkcserver0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcserver0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcsoap0.
    Preparing to unpack libkcsoap0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcsoap0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcssl0.
    Preparing to unpack libkcssl0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcssl0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcsync0.
    Preparing to unpack libkcsync0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcsync0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libkcutil0.
    Preparing to unpack libkcutil0_8.4.0~792-150.1_amd64.deb ...
    Unpacking libkcutil0 (8.4.0~792-150.1) ...
    Selecting previously unselected package libmapi1.
    Preparing to unpack libmapi1_8.4.0~792-150.1_amd64.deb ...
    Unpacking libmapi1 (8.4.0~792-150.1) ...
    Preparing to unpack libs3-3_3.0~git226-5.1_amd64.deb ...
    Unpacking libs3-3 (3.0~git226-5.1) over (3.0~git226-5.1) ...
    Preparing to unpack libs3-dev_3.0~git226-5.1_amd64.deb ...
    Unpacking libs3-dev (3.0~git226-5.1) over (3.0~git226-5.1) ...
    Preparing to unpack libtidy5_5.1.9-1.1_amd64.deb ...
    Unpacking libtidy5 (5.1.9-1.1) over (5.1.9-1.1) ...
    Preparing to unpack libvmime-kopano-dev_0.9.2-9.1_amd64.deb ...
    Unpacking libvmime-kopano-dev (0.9.2-9.1) over (0.9.2-9.1) ...
    Preparing to unpack libvmime-kopano1_0.9.2-9.1_amd64.deb ...
    Unpacking libvmime-kopano1 (0.9.2-9.1) over (0.9.2-9.1) ...
    Selecting previously unselected package php5-mapi.
    Preparing to unpack php5-mapi_8.4.0~792-150.1_amd64.deb ...
    Unpacking php5-mapi (8.4.0~792-150.1) ...
    Selecting previously unselected package python-kopano.
    Preparing to unpack python-kopano_8.4.0~792-150.1_all.deb ...
    Unpacking python-kopano (8.4.0~792-150.1) ...
    Selecting previously unselected package python-mapi.
    Preparing to unpack python-mapi_8.4.0~792-150.1_amd64.deb ...
    Unpacking python-mapi (8.4.0~792-150.1) ...
    Preparing to unpack tidy-html5-dev_5.1.9-1.1_amd64.deb ...
    Unpacking tidy-html5-dev (5.1.9-1.1) ...
    dpkg: error processing archive tidy-html5-dev_5.1.9-1.1_amd64.deb (--install):
     trying to overwrite '/usr/lib/libtidy.so', which is also in package libtidy-0.99-0 20091223cvs-1.5
    Preparing to unpack tidy-html5_5.1.9-1.1_amd64.deb ...
    Unpacking tidy-html5 (5.1.9-1.1) over (5.1.9-1.1) ...
    Setting up gsoap-kopano-doc (2.8.43-3.1) ...
    Setting up kopano-bash-completion (8.4.0~792-150.1) ...
    Setting up kopano-common (8.4.0~792-150.1) ...
    dpkg: dependency problems prevent configuration of kopano-dagent:
     kopano-dagent depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     kopano-dagent depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package kopano-dagent (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-dbg (8.4.0~792-150.1) ...
    dpkg: dependency problems prevent configuration of kopano-dev:
     kopano-dev depends on libicu-dev; however:
      Package libicu-dev is not installed.
    
    dpkg: error processing package kopano-dev (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-gateway:
     kopano-gateway depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package kopano-gateway (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-ical:
     kopano-ical depends on libical1a (>= 1.0); however:
      Package libical1a is not installed.
     kopano-ical depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package kopano-ical (--install):
     dependency problems - leaving unconfigured
    Setting up kopano-lang (8.4.0~792-150.1) ...
    Setting up kopano-migration-imap (8.4.0~792-150.1) ...
    dpkg: dependency problems prevent configuration of kopano-presence:
     kopano-presence depends on python-flask; however:
      Package python-flask is not installed.
     kopano-presence depends on python-sleekxmpp; however:
      Package python-sleekxmpp is not installed.
    
    dpkg: error processing package kopano-presence (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-search:
     kopano-search depends on python-xapian; however:
      Package python-xapian is not installed.
     kopano-search depends on catdoc; however:
      Package catdoc is not installed.
    
    dpkg: error processing package kopano-search (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-server-packages:
     kopano-server-packages depends on kopano-dagent (= 8.4.0~792-150.1); however:
      Package kopano-dagent is not configured yet.
     kopano-server-packages depends on kopano-gateway (= 8.4.0~792-150.1); however:
      Package kopano-gateway is not configured yet.
     kopano-server-packages depends on kopano-ical (= 8.4.0~792-150.1); however:
      Package kopano-ical is not configured yet.
     kopano-server-packages depends on kopano-presence (= 8.4.0~792-150.1); however:
      Package kopano-presence is not configured yet.
     kopano-server-packages depends on kopano-search (= 8.4.0~792-150.1); however:
      Package kopano-search is not configured yet.
    
    dpkg: error processing package kopano-server-packages (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-server:
     kopano-server depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     kopano-server depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
     kopano-server depends on libtcmalloc-minimal4; however:
      Package libtcmalloc-minimal4 is not installed.
    
    dpkg: error processing package kopano-server (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-spooler:
     kopano-spooler depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     kopano-spooler depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package kopano-spooler (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-utils:
     kopano-utils depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package kopano-utils (--install):
     dependency problems - leaving unconfigured
    Setting up libgsoap-kopano-2-8-43 (2.8.43-3.1) ...
    Setting up libgsoap-kopano-dbg (2.8.43-3.1) ...
    dpkg: dependency problems prevent configuration of libjansson-doc:
     libjansson-doc depends on libjs-backbone; however:
      Package libjs-backbone is not installed.
    
    dpkg: error processing package libjansson-doc (--install):
     dependency problems - leaving unconfigured
    Setting up libjansson4:amd64 (2.7-1) ...
    dpkg: dependency problems prevent configuration of libkcarchivercore0:
     libkcarchivercore0 depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package libkcarchivercore0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcicalmapi0:
     libkcicalmapi0 depends on libical1a (>= 1.0); however:
      Package libical1a is not installed.
    
    dpkg: error processing package libkcicalmapi0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcinetmapi0:
     libkcinetmapi0 depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
    
    dpkg: error processing package libkcinetmapi0 (--install):
     dependency problems - leaving unconfigured
    Setting up libkcpydirector0 (8.4.0~792-150.1) ...
    dpkg: dependency problems prevent configuration of libkcserver0:
     libkcserver0 depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
     libkcserver0 depends on libmysqlclient18 (>= 5.5.24+dfsg-1); however:
      Package libmysqlclient18 is not installed.
    
    dpkg: error processing package libkcserver0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcutil0:
     libkcutil0 depends on libicu52 (>= 52~m1-1~); however:
      Package libicu52 is not installed.
    
    dpkg: error processing package libkcutil0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libmapi1:
     libmapi1 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libmapi1 (--install):
     dependency problems - leaving unconfigured
    Setting up libs3-3 (3.0~git226-5.1) ...
    Setting up libs3-dev (3.0~git226-5.1) ...
    Setting up libtidy5 (5.1.9-1.1) ...
    Setting up libvmime-kopano1 (0.9.2-9.1) ...
    dpkg: dependency problems prevent configuration of php5-mapi:
     php5-mapi depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
     php5-mapi depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
     php5-mapi depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     php5-mapi depends on libmapi1; however:
      Package libmapi1 is not configured yet.
     php5-mapi depends on phpapi-20131226; however:
      Package phpapi-20131226 is not installed.
    
    dpkg: error processing package php5-mapi (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-kopano:
     python-kopano depends on python-dateutil; however:
      Package python-dateutil is not installed.
    
    dpkg: error processing package python-kopano (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of python-mapi:
     python-mapi depends on libical1a (>= 1.0); however:
      Package libical1a is not installed.
     python-mapi depends on libkcicalmapi0; however:
      Package libkcicalmapi0 is not configured yet.
     python-mapi depends on libkcinetmapi0; however:
      Package libkcinetmapi0 is not configured yet.
     python-mapi depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     python-mapi depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package python-mapi (--install):
     dependency problems - leaving unconfigured
    Setting up tidy-html5 (5.1.9-1.1) ...
    Setting up gsoap-kopano-dev (2.8.43-3.1) ...
    Setting up gsoap-kopano (2.8.43-3.1) ...
    dpkg: dependency problems prevent configuration of kopano-backup:
     kopano-backup depends on python-kopano; however:
      Package python-kopano is not configured yet.
    
    dpkg: error processing package kopano-backup (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-client:
     kopano-client depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     kopano-client depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package kopano-client (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-contacts:
     kopano-contacts depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     kopano-contacts depends on libmapi1; however:
      Package libmapi1 is not configured yet.
     kopano-contacts depends on kopano-client (= 8.4.0~792-150.1); however:
      Package kopano-client is not configured yet.
    
    dpkg: error processing package kopano-contacts (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-migration-pst:
     kopano-migration-pst depends on python-kopano; however:
      Package python-kopano is not configured yet.
    
    dpkg: error processing package kopano-migration-pst (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of kopano-monitor:
     kopano-monitor depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     kopano-monitor depends on libmapi1; however:
      Package libmapi1 is not configured yet.
     kopano-monitor depends on kopano-client (= 8.4.0~792-150.1); however:
      Package kopano-client is not configured yet.
    
    dpkg: error processing package kopano-monitor (--install):
     dependency problems - leaving unconfigured
    Setting up libjansson-dbg:amd64 (2.7-1) ...
    Setting up libjansson-dev:amd64 (2.7-1) ...
    dpkg: dependency problems prevent configuration of libkcarchiver0:
     libkcarchiver0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     libkcarchiver0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcarchiver0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcfreebusy0:
     libkcfreebusy0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
     libkcfreebusy0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcfreebusy0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkchl0:
     libkchl0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkchl0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcmapi0:
     libkcmapi0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libkcmapi0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcpyconv0:
     libkcpyconv0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcpyconv0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcsoap0:
     libkcsoap0 depends on libkcmapi0; however:
      Package libkcmapi0 is not configured yet.
     libkcsoap0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libkcsoap0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcssl0:
     libkcssl0 depends on libkcutil0; however:
      Package libkcutil0 is not configured yet.
    
    dpkg: error processing package libkcssl0 (--install):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of libkcsync0:
     libkcsync0 depends on libkcmapi0; however:
      Package libkcmapi0 is not configured yet.
     libkcsync0 depends on libmapi1; however:
      Package libmapi1 is not configured yet.
    
    dpkg: error processing package libkcsync0 (--install):
     dependency problems - leaving unconfigured
    Setting up libvmime-kopano-dev (0.9.2-9.1) ...
    Setting up gsoap-kopano-dbg (2.8.43-3.1) ...
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for systemd (229-4ubuntu17) ...
    Processing triggers for libc-bin (2.23-0ubuntu7) ...
    Errors were encountered while processing:
     tidy-html5-dev_5.1.9-1.1_amd64.deb
     kopano-dagent
     kopano-dev
     kopano-gateway
     kopano-ical
     kopano-presence
     kopano-search
     kopano-server-packages
     kopano-server
     kopano-spooler
     kopano-utils
     libjansson-doc
     libkcarchivercore0
     libkcicalmapi0
     libkcinetmapi0
     libkcserver0
     libkcutil0
     libmapi1
     php5-mapi
     python-kopano
     python-mapi
     kopano-backup
     kopano-client
     kopano-contacts
     kopano-migration-pst
     kopano-monitor
     libkcarchiver0
     libkcfreebusy0
     libkchl0
     libkcmapi0
     libkcpyconv0
     libkcsoap0
     libkcssl0
     libkcsync0
    
    

  • Kopano

    hm… do you have any third party repositories configured? for my installing libjansson-doc does not create such conflicts. But as said earlier not all packages in the archive need to be installed anyways, libjansson-doc is such an example.

    To make it easier to resolve dependencies I always recommend to not use dpkg for the installation, but to create an ad-hoc apt repo from the downloaded archives. just extract the archives, cd into the directories just create and then create the repo with apt-ftparchives. I have the following script for this in my toolbox:

    #!/bin/bash
    
    read -p "Create a local apt repo from the current dir? (y/n) " RESP
    if [ "$RESP" = "y" ]; then
            apt-ftparchive packages . | gzip -9c > Packages.gz
    fi
    
    echo "To use this repo just add the following line to /etc/apt/sources.list:"
    echo "deb file:$(pwd) ./"
    echo
    echo "To skip verification you can call apt-get the following way:"
    echo "apt-get install --allow-unauthenticated kopano-server-packages"
    


  • @fbartels said in Install Kopano Core on Ubuntu 16.04 error -:

    hm… do you have any third party repositories configured? for my installing libjansson-doc does not create such conflicts. But as said earlier not all packages in the archive need to be installed anyways, libjansson-doc is such an example.

    To make it easier to resolve dependencies I always recommend to not use dpkg for the installation, but to create an ad-hoc apt repo from the downloaded archives. just extract the archives, cd into the directories just create and then create the repo with apt-ftparchives. I have the following script for this in my toolbox:

    #!/bin/bash
    
    read -p "Create a local apt repo from the current dir? (y/n) " RESP
    if [ "$RESP" = "y" ]; then
            apt-ftparchive packages . | gzip -9c > Packages.gz
    fi
    
    echo "To use this repo just add the following line to /etc/apt/sources.list:"
    echo "deb file:$(pwd) ./"
    echo
    echo "To skip verification you can call apt-get the following way:"
    echo "apt-get install --allow-unauthenticated kopano-server-packages"
    

    Have I understood it correctly?

    1. Download the newest core-package with wget.
    2. Extract these with tar -xvf.
    3. Cd into extracted directory.
    4. Create a new skript for example “kopano.sh” and copy your script 1:1 from above.
    5. add the line “deb file:$(pwd) ./” to my sources.list
    6. use command “apt-get install --allow-unauthenticated kopano-server-packages”

    Is this the right way?



  • I renember having issues with libjansson too. I think I solved it by installing libjansson-doc manually. Looks like a change or bug in the libjansson dependencies.


  • Kopano

    @nils50122 yes, that sounds correct



  • @fbartels

    now i have a package named packages.gz in my kopano directory.

    
    root@xxxxx:/tmp/core-8.4.0~792_151.1-Debian_8.0-amd64# ls -a
    .
    ..
    Packages.gz
    gsoap-kopano-dbg_2.8.43-3.1_amd64.deb
    gsoap-kopano-dev_2.8.43-3.1_amd64.deb
    gsoap-kopano-doc_2.8.43-3.1_all.deb
    gsoap-kopano_2.8.43-3.1_amd64.deb
    kopano-backup_8.4.0~792-151.1_amd64.deb
    kopano-bash-completion_8.4.0~792-151.1_amd64.deb
    kopano-client_8.4.0~792-151.1_amd64.deb
    kopano-common_8.4.0~792-151.1_amd64.deb
    kopano-contacts_8.4.0~792-151.1_amd64.deb
    kopano-dagent_8.4.0~792-151.1_amd64.deb
    kopano-dbg_8.4.0~792-151.1_amd64.deb
    kopano-dev_8.4.0~792-151.1_amd64.deb
    kopano-gateway_8.4.0~792-151.1_amd64.deb
    kopano-ical_8.4.0~792-151.1_amd64.deb
    kopano-lang_8.4.0~792-151.1_all.deb
    kopano-migration-imap_8.4.0~792-151.1_amd64.deb
    kopano-migration-pst_8.4.0~792-151.1_amd64.deb
    kopano-monitor_8.4.0~792-151.1_amd64.deb
    kopano-presence_8.4.0~792-151.1_amd64.deb
    kopano-search_8.4.0~792-151.1_amd64.deb
    kopano-server-packages_8.4.0~792-151.1_all.deb
    kopano-server_8.4.0~792-151.1_amd64.deb
    kopano-spooler_8.4.0~792-151.1_amd64.deb
    kopano-utils_8.4.0~792-151.1_amd64.deb
    kopano.sh
    libgsoap-kopano-2-8-43_2.8.43-3.1_amd64.deb
    libgsoap-kopano-dbg_2.8.43-3.1_amd64.deb
    libjansson-dbg_2.7-1_amd64.deb
    libjansson-dev_2.7-1_amd64.deb
    libjansson-doc_2.7-1_all.deb
    libjansson4_2.7-1_amd64.deb
    libkcarchiver0_8.4.0~792-151.1_amd64.deb
    libkcarchivercore0_8.4.0~792-151.1_amd64.deb
    libkcfreebusy0_8.4.0~792-151.1_amd64.deb
    libkchl0_8.4.0~792-151.1_amd64.deb
    libkcicalmapi0_8.4.0~792-151.1_amd64.deb
    libkcinetmapi0_8.4.0~792-151.1_amd64.deb
    libkcmapi0_8.4.0~792-151.1_amd64.deb
    libkcpyconv0_8.4.0~792-151.1_amd64.deb
    libkcpydirector0_8.4.0~792-151.1_amd64.deb
    libkcserver0_8.4.0~792-151.1_amd64.deb
    libkcsoap0_8.4.0~792-151.1_amd64.deb
    libkcssl0_8.4.0~792-151.1_amd64.deb
    libkcsync0_8.4.0~792-151.1_amd64.deb
    libkcutil0_8.4.0~792-151.1_amd64.deb
    libmapi1_8.4.0~792-151.1_amd64.deb
    libs3-3_3.0~git226-5.1_amd64.deb
    libs3-dev_3.0~git226-5.1_amd64.deb
    libtidy5_5.1.9-1.1_amd64.deb
    libvmime-kopano-dev_0.9.2-9.1_amd64.deb
    libvmime-kopano1_0.9.2-9.1_amd64.deb
    php5-mapi_8.4.0~792-151.1_amd64.deb
    python-kopano_8.4.0~792-151.1_all.deb
    python-mapi_8.4.0~792-151.1_amd64.deb
    tidy-html5-dev_5.1.9-1.1_amd64.deb
    tidy-html5_5.1.9-1.1_amd64.deb
    

    I added the line “deb file:/tmp/core-8.4.0~792_151.1-Debian_8.0-amd64 ./” to my sources.list

    but where is the way to install this now?
    when i use your command from the script i become this error:

    root@xxxx:/etc/apt# apt-get install --allow-unauthenticated kopano-server-packages
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package kopano-server-packages
    

  • Kopano

    @nils50122 did you also run apt-get update?



  • @fbartels

    Ah, apt-get update was the problem.

    Now i become these erros:

    
    root@xxxxx:/etc/apt# apt-get install --allow-unauthenticated kopano-server-packages
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     kopano-server-packages : Depends: kopano-backup (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-dagent (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-gateway (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-ical (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-monitor (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-presence (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-search (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-server (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-spooler (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-utils (= 8.4.0~792-151.1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    

  • Kopano

    @nils50122 hm… maybe your previous attempts left some leftover, that are now blocking install. The same apt line worked just fine this morning.

    Could you run the following: apt-get -s -o Debug::pkgProblemResolver=yes install kopano-server-packages

    This should give some more insights why he cannot resolve the package dependencies.



  • @fbartels

    here’s the output:

    root@xxxxx:/# apt-get -s -o Debug::pkgProblemResolver=yes install kopano-server-packages
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Starting pkgProblemResolver with broken count: 11
    Starting 2 pkgProblemResolver with broken count: 11
    Investigating (0) kopano-server-packages [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-server-packages:amd64 Depends on kopano-dagent [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-dagent:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-gateway [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-gateway:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-ical [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-ical:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-server [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-server:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-spooler [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-spooler:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-utils [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-utils:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
    Investigating (0) libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcmapi0:amd64 Depends on libkcutil0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcutil0:amd64 10 as a solution to libkcmapi0:amd64 21
      Holding Back libkcmapi0:amd64 rather than change libkcutil0:amd64
    Investigating (0) libmapi1 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libmapi1:amd64 Depends on libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcmapi0:amd64 21 as a solution to libmapi1:amd64 13
      Holding Back libmapi1:amd64 rather than change libkcmapi0:amd64
    Investigating (0) kopano-client [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-client:amd64 Depends on libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcmapi0:amd64 21 as a solution to kopano-client:amd64 9
      Holding Back kopano-client:amd64 rather than change libkcmapi0:amd64
    Investigating (0) libkcfreebusy0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcfreebusy0:amd64 Depends on libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcmapi0:amd64 21 as a solution to libkcfreebusy0:amd64 5
      Holding Back libkcfreebusy0:amd64 rather than change libkcmapi0:amd64
    Investigating (0) libkcsync0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcsync0:amd64 Depends on libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcmapi0:amd64 21 as a solution to libkcsync0:amd64 3
      Holding Back libkcsync0:amd64 rather than change libkcmapi0:amd64
    Investigating (0) python-mapi [ amd64 ] < none -> 8.4.0~792-151.1 > ( python )
    Broken python-mapi:amd64 Depends on libkcfreebusy0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcfreebusy0:amd64 5 as a solution to python-mapi:amd64 2
      Holding Back python-mapi:amd64 rather than change libkcfreebusy0:amd64
    Investigating (0) libkcsoap0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcsoap0:amd64 Depends on libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcmapi0:amd64 21 as a solution to libkcsoap0:amd64 2
      Holding Back libkcsoap0:amd64 rather than change libkcmapi0:amd64
    Investigating (0) python-kopano [ amd64 ] < none -> 8.4.0~792-151.1 > ( python )
    Broken python-kopano:amd64 Depends on python-mapi [ amd64 ] < none -> 8.4.0~792-151.1 > ( python )
      Considering python-mapi:amd64 2 as a solution to python-kopano:amd64 2
      Holding Back python-kopano:amd64 rather than change python-mapi:amd64
    Investigating (0) libkcssl0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcssl0:amd64 Depends on libkcutil0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcutil0:amd64 10 as a solution to libkcssl0:amd64 2
      Holding Back libkcssl0:amd64 rather than change libkcutil0:amd64
    Investigating (0) libkcicalmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcicalmapi0:amd64 Depends on libkcfreebusy0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcfreebusy0:amd64 5 as a solution to libkcicalmapi0:amd64 1
      Holding Back libkcicalmapi0:amd64 rather than change libkcfreebusy0:amd64
    Investigating (0) kopano-search [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-search:amd64 Depends on python-kopano [ amd64 ] < none -> 8.4.0~792-151.1 > ( python )
      Considering python-kopano:amd64 2 as a solution to kopano-search:amd64 0
      Holding Back kopano-search:amd64 rather than change python-kopano:amd64
    Investigating (0) libkcinetmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcinetmapi0:amd64 Depends on libkcicalmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcicalmapi0:amd64 1 as a solution to libkcinetmapi0:amd64 0
      Holding Back libkcinetmapi0:amd64 rather than change libkcicalmapi0:amd64
    Investigating (0) kopano-backup [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-backup:amd64 Depends on python-kopano [ amd64 ] < none -> 8.4.0~792-151.1 > ( python )
      Considering python-kopano:amd64 2 as a solution to kopano-backup:amd64 0
      Holding Back kopano-backup:amd64 rather than change python-kopano:amd64
    Investigating (0) kopano-presence [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-presence:amd64 Depends on python-kopano [ amd64 ] < none -> 8.4.0~792-151.1 > ( python )
      Considering python-kopano:amd64 2 as a solution to kopano-presence:amd64 0
      Holding Back kopano-presence:amd64 rather than change python-kopano:amd64
    Investigating (0) libkcpyconv0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken libkcpyconv0:amd64 Depends on libmapi1 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libmapi1:amd64 13 as a solution to libkcpyconv0:amd64 0
      Holding Back libkcpyconv0:amd64 rather than change libmapi1:amd64
    Investigating (0) kopano-monitor [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-monitor:amd64 Depends on libkcmapi0 [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
      Considering libkcmapi0:amd64 21 as a solution to kopano-monitor:amd64 0
      Holding Back kopano-monitor:amd64 rather than change libkcmapi0:amd64
    Investigating (1) kopano-server-packages [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail )
    Broken kopano-server-packages:amd64 Depends on kopano-backup [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-backup:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed early because of libicu52:amd64
        Reinst Failed because of libkcutil0:amd64
        Reinst Failed because of libkcmapi0:amd64
        Reinst Failed because of libkcfreebusy0:amd64
        Reinst Failed because of python-mapi:amd64
        Reinst Failed because of python-kopano:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-dagent [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-dagent:amd64 0 as a solution to kopano-server-packages:amd64 9999
    Broken kopano-server-packages:amd64 Depends on kopano-gateway [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-gateway:amd64 0 as a solution to kopano-server-packages:amd64 9999
    Broken kopano-server-packages:amd64 Depends on kopano-ical [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-ical:amd64 0 as a solution to kopano-server-packages:amd64 9999
    Broken kopano-server-packages:amd64 Depends on kopano-monitor [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-monitor:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed because of libkcmapi0:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-presence [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-presence:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed because of python-kopano:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-search [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-search:amd64 0 as a solution to kopano-server-packages:amd64 9999
        Reinst Failed because of python-kopano:amd64
    Broken kopano-server-packages:amd64 Depends on kopano-server [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-server:amd64 0 as a solution to kopano-server-packages:amd64 9999
    Broken kopano-server-packages:amd64 Depends on kopano-spooler [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-spooler:amd64 0 as a solution to kopano-server-packages:amd64 9999
    Broken kopano-server-packages:amd64 Depends on kopano-utils [ amd64 ] < none -> 8.4.0~792-151.1 > ( mail ) (= 8.4.0~792-151.1)
      Considering kopano-utils:amd64 0 as a solution to kopano-server-packages:amd64 9999
    Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     kopano-server-packages : Depends: kopano-backup (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-dagent (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-gateway (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-ical (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-monitor (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-presence (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-search (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-server (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-spooler (= 8.4.0~792-151.1) but it is not going to be installed
                              Depends: kopano-utils (= 8.4.0~792-151.1) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    

  • Kopano

    Ah found the reason you cannot resolve all dependencies: you are trying to install the packages from Debian 8 on Ubuntu 16.04.

    @nils50122 said in Install Kopano Core on Ubuntu 16.04 error -:

    root@xxxxx:/tmp/core-8.4.0~792_151.1-Debian_8.0-amd64#



  • @fbartels

    Now the installation is ok.
    Only the package libjasson fault, but you say its not important.

    The WebApp-Package installed successfull, restart the apache2 process after it, but when i try to connect the URL: http://xxx.xxx.de/webapp/ there comes an error 500 from apache.

    When i restart the apache process there are no faults.


  • Kopano

    @nils50122 anything in the apache (error) logs? are you now using the 16.04 packages? for webapp and core?

    which version do you have installed?



  • @fbartels

    here’s the error log from apache.

    [Tue Jun 20 16:19:39.465221 2017] [mpm_prefork:notice] [pid 8686] AH00169: caught SIGTERM, shutting down
    [Tue Jun 20 16:19:40.573970 2017] [ssl:warn] [pid 28362] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:19:40.574242 2017] [ssl:warn] [pid 28362] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:19:40.574312 2017] [suexec:notice] [pid 28362] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jun 20 16:19:40.584621 2017] [auth_digest:notice] [pid 28363] AH01757: generating secret for digest authentication ...
    [Tue Jun 20 16:19:40.587812 2017] [ssl:warn] [pid 28363] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:19:40.588095 2017] [ssl:warn] [pid 28363] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:19:40.588744 2017] [mpm_prefork:notice] [pid 28363] AH00163: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jun 20 16:19:40.588759 2017] [core:notice] [pid 28363] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jun 20 16:20:07.990882 2017] [mpm_prefork:notice] [pid 28363] AH00169: caught SIGTERM, shutting down
    [Tue Jun 20 16:20:09.079958 2017] [ssl:warn] [pid 29914] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:20:09.080257 2017] [ssl:warn] [pid 29914] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:20:09.080337 2017] [suexec:notice] [pid 29914] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jun 20 16:20:09.090137 2017] [auth_digest:notice] [pid 29915] AH01757: generating secret for digest authentication ...
    [Tue Jun 20 16:20:09.093250 2017] [ssl:warn] [pid 29915] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:20:09.093488 2017] [ssl:warn] [pid 29915] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:20:09.094192 2017] [mpm_prefork:notice] [pid 29915] AH00163: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jun 20 16:20:09.094208 2017] [core:notice] [pid 29915] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jun 20 16:22:43.072352 2017] [mpm_prefork:notice] [pid 29915] AH00171: Graceful restart requested, doing restart
    [Tue Jun 20 16:22:46.086263 2017] [auth_digest:notice] [pid 29915] AH01757: generating secret for digest authentication ...
    [Tue Jun 20 16:22:46.088281 2017] [ssl:warn] [pid 29915] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:22:46.088563 2017] [ssl:warn] [pid 29915] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:22:46.088729 2017] [mpm_prefork:notice] [pid 29915] AH00163: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jun 20 16:22:46.088737 2017] [core:notice] [pid 29915] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jun 20 16:22:46.333456 2017] [core:alert] [pid 2108] [client 87.174.179.87:50696] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:22:49.506368 2017] [core:alert] [pid 2108] [client 87.174.179.87:50698] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:22:50.888586 2017] [core:alert] [pid 2108] [client 87.174.179.87:50699] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:22:52.915566 2017] [core:alert] [pid 2108] [client 87.174.179.87:50700] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:23:09.278796 2017] [mpm_prefork:notice] [pid 29915] AH00169: caught SIGTERM, shutting down
    [Tue Jun 20 16:23:10.372162 2017] [ssl:warn] [pid 2153] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:23:10.372471 2017] [ssl:warn] [pid 2153] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:23:10.372548 2017] [suexec:notice] [pid 2153] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jun 20 16:23:10.383492 2017] [auth_digest:notice] [pid 2154] AH01757: generating secret for digest authentication ...
    [Tue Jun 20 16:23:10.386513 2017] [ssl:warn] [pid 2154] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:23:10.386971 2017] [ssl:warn] [pid 2154] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:23:10.389558 2017] [mpm_prefork:notice] [pid 2154] AH00163: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jun 20 16:23:10.389581 2017] [core:notice] [pid 2154] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jun 20 16:23:12.171822 2017] [core:alert] [pid 2159] [client 87.174.179.87:50702] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:23:13.985263 2017] [core:alert] [pid 2159] [client 87.174.179.87:50703] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:23:14.958933 2017] [core:alert] [pid 2159] [client 87.174.179.87:50704] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:23:26.736460 2017] [core:alert] [pid 2164] [client 87.174.179.87:50712] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:23:44.436729 2017] [core:alert] [pid 2163] [client 87.174.179.87:50723] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:23:50.701906 2017] [core:alert] [pid 2166] [client 87.174.179.87:50725] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:26:45.902095 2017] [core:alert] [pid 2163] [client 87.174.179.87:50743] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:28:52.617819 2017] [core:alert] [pid 2163] [client 87.174.179.87:50756] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:29:06.564261 2017] [mpm_prefork:notice] [pid 2154] AH00169: caught SIGTERM, shutting down
    [Tue Jun 20 16:29:07.654007 2017] [ssl:warn] [pid 3208] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:29:07.654311 2017] [ssl:warn] [pid 3208] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:29:07.654427 2017] [suexec:notice] [pid 3208] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jun 20 16:29:07.665162 2017] [auth_digest:notice] [pid 3209] AH01757: generating secret for digest authentication ...
    [Tue Jun 20 16:29:07.668170 2017] [ssl:warn] [pid 3209] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:29:07.668418 2017] [ssl:warn] [pid 3209] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:29:07.669145 2017] [mpm_prefork:notice] [pid 3209] AH00163: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jun 20 16:29:07.669160 2017] [core:notice] [pid 3209] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jun 20 16:29:11.011963 2017] [core:alert] [pid 3214] [client 87.174.179.87:50758] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:32:56.990207 2017] [mpm_prefork:notice] [pid 3209] AH00169: caught SIGTERM, shutting down
    [Tue Jun 20 16:32:58.093561 2017] [ssl:warn] [pid 3655] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:32:58.093873 2017] [ssl:warn] [pid 3655] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:32:58.093977 2017] [suexec:notice] [pid 3655] AH01232: suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
    [Tue Jun 20 16:32:58.104575 2017] [auth_digest:notice] [pid 3656] AH01757: generating secret for digest authentication ...
    [Tue Jun 20 16:32:58.107586 2017] [ssl:warn] [pid 3656] AH01909: lists:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:32:58.107822 2017] [ssl:warn] [pid 3656] AH01909: default-178_254_35_190:443:0 server certificate does NOT include an ID which matches the server name
    [Tue Jun 20 16:32:58.108549 2017] [mpm_prefork:notice] [pid 3656] AH00163: Apache/2.4.18 (Ubuntu) mod_fcgid/2.3.9 OpenSSL/1.0.2g configured -- resuming normal operations
    [Tue Jun 20 16:32:58.108568 2017] [core:notice] [pid 3656] AH00094: Command line: '/usr/sbin/apache2'
    [Tue Jun 20 16:33:01.971126 2017] [core:alert] [pid 3661] [client 87.174.179.87:50901] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    [Tue Jun 20 16:51:06.225207 2017] [core:alert] [pid 3661] [client 87.174.179.87:51454] /usr/share/kopano-webapp/.htaccess: Invalid command 'php_value', perhaps misspelled or defined by a module not included in the server configuration
    

    used the package for ubuntu 16.04 from tonight. (https://download.kopano.io/community/webapp:/webapp-3.4.0.715_494-Ubuntu_16.04-all.tar.gz)

    I think there is a error in the .htaccess with my php7.


  • Kopano

    @nils50122 are you running php-fpm?

    Yes, the htaccess seems to be the problem.


Log in to reply
 

Looks like your connection to Kopano Community Forum was lost, please wait while we try to reconnect.