Kopano Groupware Core 8.7.3 Final Available


  • Kopano

    Hello everyone,

    We just released the Kopano Groupware Core 8.7.3 version to the download servers.

    The 8.7.2 release was never pushed to the download server, due to some issues that are now resolved in 8.7.3.

    For more details on the fixes and updates check out the changelog.

    Use the repositories to update your system, or alternatively get the packages from the portal or directly from the download page itself.

    We’re already working hard on the next (8.7.4) release, so keep an eye out for updates on it.

    As always, any feedback is more than welcome!



  • its release yes, really,?

    so this is correct?
    Kopano Core 8.7.3 Final (8.7.3.0)
    Released: 2019-06-06 <<< ?

    and is this one also in community packages?
    https://github.com/Kopano-dev/kopano-core/pull/16/commits/9c0df9342d70a029f18895d088205cb0fb2a58a0

    Is the documentation also updated to 8.7? because its so far behind?


  • Kopano

    @thctlo said in Kopano Groupware Core 8.7.3 Final Available:

    so this is correct?
    Kopano Core 8.7.3 Final (8.7.3.0)
    Released: 2019-06-06 <<< ?

    Yes, that would be the date when these packages were initially released as pre-final

    @thctlo said in Kopano Groupware Core 8.7.3 Final Available:

    and is this one also in community packages?

    The community nightly packages and the official releases are two very different things. While the nightly packages are build from the master branch of the Kopano Groupware Core git repository, the releases for our customers are built from dedicated release branches. The linked issue is something that only occurs in master and not in the releases.

    @thctlo said in Kopano Groupware Core 8.7.3 Final Available:

    Is the documentation also updated to 8.7? because its so far behind?

    I have already asked you in https://forum.kopano.io/topic/2401/latest-documentation/ whay exactly are you missing in the documentation? Are you concerned because it says “Edition 8.3.0” on the index page?



  • @Joost : it seems that Ubuntu Packages for 8.7.3 have an issue in supported downloads:

    The following packages have unmet dependencies:
     kopano-archiver : Depends: libkcarchiver0 (= 8.7.3.0-0+3.1) but 8.7.3.0-0+30.1 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    So the requirements for kopano-archiver are wrong and does not match…

    The bad thing is that because of unmet dependencies an apt-get dist-upgrade will automatically remove the kopano-archiver package :-( To install it again just try following:

    apt-get download kopano-archiver
    dpkg --force-all -i kopano-archiver_8.7.3.0-0+3.1_amd64.deb
    
    

    After this treatment the apt-get dist-upgrade will claim about problem and suggests to run apt-get install -f… If you want to have kopano-archiver uninstalled again just follow this idea ;-) Otherwise wait until kopano fixes the package and the problem should disappear, too.


  • Kopano

    @dw2412 thank you for the feedback.

    This issue should now be resolved.

    Something went wrong with the version-numbering, all packages now have the correct version number.

    If you have any other issues, please let us know!



  • @Joost yes - somehow… Only way to get the fixed packages installed was to remove the old once and install everything new. Any idea if there is a better way to do this? I just think in direction of paying customers that might feel some discomfort in removing everything just to reinstall it…



  • @fbartels said in Kopano Groupware Core 8.7.3 Final Available:

    I have already asked you in https://forum.kopano.io/topic/2401/latest-documentation/ whay exactly are you missing in the documentation? Are you concerned because it says “Edition 8.3.0” on the index page?

    Hai Felix,

    The community nightly packages and the official releases are two very different things. While the nightly > packages are build from the master branch of the Kopano Groupware Core git repository, the releases for > our customers are built from dedicated release branches.

    maybe adding an alias for “community” to nightly will show more people that these are development packages and not community supported, as it now looks like it.

    Are you concerned because it says “Edition 8.3.0” on the index page?
    No, you already explained that to me, but for others this might still be confusing.
    I wish i had the time to go through it more and post some needed changes, but im missing time to do this…

    When i look at Chapter 5. ( configuring KC-components)
    The order in sub chapters is that also the preferred install method?
    As in, is this now preffered to setup kopano-kconnectd ? (5.2) ?

    Greetz,

    Louis


  • Kopano

    @dw2412 said in Kopano Groupware Core 8.7.3 Final Available:

    @Joost yes - somehow… Only way to get the fixed packages installed was to remove the old once and install everything new. Any idea if there is a better way to do this? I just think in direction of paying customers that might feel some discomfort in removing everything just to reinstall it…

    When you say the ‘old’ ones, I assume you mean the packages with the incorrect version: 8.7.3.0+30.1? These ‘old’ packages contain the exact same binaries as the packages published today, so there is no need to replace one for the other, and both can be upgraded with any new release in the future.

    Upgrading to the current final ( 8.7.3.0+3.1 ) from previous finals works without removing or reinstalling packages.



  • @Joost Yes - with old I mean the packages before name change. Actually I cannot confirm what you say regarding the packages can be updated and everything is fine.

    If I try to reinstall the kopano archiver it still shows the already known error. If I try to run apt-get update, apt-get upgrade or apt-get dist-upgrade the wrong numbered packages will not be replaced. Actually nothing happens since no update being found. This is why I said I had to remove them all and reinstall them afterwards again.

    Andreas


  • Kopano

    @dw2412 said in Kopano Groupware Core 8.7.3 Final Available:

    Actually I cannot confirm what you say regarding the packages can be updated and everything is fine.

    This is in regards to future releases like 8.7.4 or 8.8.0 for example.
    Upgrading from 8.7.1 (or earlier releases) to 8.7.3 should not show any issues

    the wrong numbered packages will not be replaced. Actually nothing happens since no update being found. This is why I said I had to remove them all and reinstall them afterwards again.

    1. The wrong numbered packages have a higher number (30 > 3), so this is why they won’t be replaced.
    2. There is no need to replace them.


  • @Joost said in Kopano Groupware Core 8.7.3 Final Available:

    There is no need to replace them.

    Just if you’ve updated with the wrong packages, got the kopano-archiver package removed and want to reinstall kopano-archiver…

    Actually if any package has a dependency set and wrong package of this dependent once being currently installed it was removed as long as broken packages have had been in repo/on server and cannot be reinstalled without my described procedure.

    Right?

    Andreas


  • Kopano

    @dw2412 said in Kopano Groupware Core 8.7.3 Final Available:

    @Joost said in Kopano Groupware Core 8.7.3 Final Available:

    There is no need to replace them.

    Just if you’ve updated with the wrong packages, got the kopano-archiver package removed and want to reinstall kopano-archiver…

    Ah, yes. If kopano-archiver got removed and other packages got upgraded to 8.7.3.0+30.1, then there could be an issue with reinstalling kopano-archiver.
    I would recommend downgrading to 8.7.3.0+3.1 in that case instead of removing/reinstalling the packages.


  • Kopano

    @thctlo said in Kopano Groupware Core 8.7.3 Final Available:

    The order in sub chapters is that also the preferred install method?
    As in, is this now preffered to setup kopano-kconnectd ?

    As with everything else you should only install components that you want to make use of. So if you want to use our rest api and konnect (because you are using meet for example) then yes you should install it.



  • I updated my own system to 8.7.3.0, unfortunately dagent and spooler rises an python exception:

    journalctl output:
    Jun 20 19:26:32 icc-zarafa kopano-dagent[1228]: Python threw an exception:
    Jun 20 19:26:32 icc-zarafa kopano-dagent[1228]: TypeError: init() takes exactly 3 arguments (2 given)
    Jun 20 19:26:33 icc-zarafa kopano-dagent[1228]: Python threw an exception:
    Jun 20 19:26:33 icc-zarafa kopano-dagent[1228]: TypeError: init() takes exactly 3 arguments (2 given)

    dagent.log:
    Thu Jun 20 19:28:31 2019: [notice ] Resolved recipient xxxxxxx.xxxx@yyyyyy.com as user XXXX
    Thu Jun 20 19:28:31 2019: [info ] Python traceback is on stderr (possibly check journalctl instead of logfile)
    Thu Jun 20 19:28:31 2019: [crit ] K-1731: Unable to initialize the dagent plugin manager: Unknown error code (1).

    Environment: SLES 12 Sp3 with all patches

    Spooler and Dagent can’t transport any mails, so my mail system is down!

    Any Ideas how to solve this problem?

    Walter


  • Kopano

    Hello @WalterHof,

    if you are experiencing an issue that impacts your ability to run Kopano I would always suggest to get in direct contact with our support. For these cases there is for example a phone number in the auto reply after the initial ticket creation.

    The easiest way out of this I see would be to simply disable the python plugin framework in spooler and dagent:

    ##############################################################
    # DAGENT PLUGIN SETTINGS
    
    # Enable the dagent plugin framework
    #plugin_enabled = no
    

    Please get in touch with our support to follow this up.



  • I already opened a support case but there is no response from support.



  • Felix,

    The SUSE packages are incomplete and therefore unusable. The Python files for the plugin Manager and Plugins are missing.
    This proves that the QS at Kopano does not work. The SUSE packages were not tested. Because of the missing Python files, you can not even send yourself an email, at least that, the QS would have noticed.

    Walter


  • Kopano

    Hi @WalterHof,

    for minor releases we are just doing a sampling of individual distributions (one deb one rpm) instead of doing a whole OS and platform qa. Seems inside of the Sles distribution a bit more changed than we anticipated, we’ll have another look at it.



  • After Upgrading my server from 8.7.1 to 8.7.1 the server is not starting anymore.

    Jul 16 13:05:46 kopano systemd[1]: Started Kopano Groupware Core Storage Server.
    Jul 16 13:05:46 kopano kopano-server[32044]: /usr/sbin/kopano-server: /usr/lib/x86_64-linux-gnu/libkcsoap.so.0: version `KC_8.7.3' not found (required by /usr/sbin/kopano-server)
    Jul 16 13:05:46 kopano kopano-server[32044]: /usr/sbin/kopano-server: /usr/lib/x86_64-linux-gnu/libkcserver.so.0: version `KC_8.7.3' not found (required by /usr/sbin/kopano-server)
    Jul 16 13:05:46 kopano kopano-server[32044]: /usr/sbin/kopano-server: /usr/lib/x86_64-linux-gnu/libkcutil.so.0: version `KC_8.7.1' not found (required by /usr/lib/x86_64-linux-gnu/libkcserver.s
    Jul 16 13:05:46 kopano kopano-server[32044]: /usr/sbin/kopano-server: /usr/lib/x86_64-linux-gnu/libkcutil.so.0: version `KC_8.7.1' not found (required by /usr/lib/x86_64-linux-gnu/libkcsoap.so.
    Jul 16 13:05:46 kopano systemd[1]: kopano-server.service: Main process exited, code=exited, status=1/FAILURE
    Jul 16 13:05:46 kopano systemd[1]: kopano-server.service: Unit entered failed state.
    Jul 16 13:05:46 kopano systemd[1]: kopano-server.service: Failed with result 'exit-code'.
    
    


  • Which OS you use?


Log in to reply