z-push 2.4.5 sync issue - 0xFFFFFFFF8004010F



  • Hi,

    I’m not sure whether this is the right place to put this thread. If not feel free to move the thread to the right location.

    How ever, I’m facing the following issue.

    Kopano and zpush is working quite nice as long no synchronization period is set. E.g. only download the mails from the last month/week/what ever period.

    As soon this is set (tested with Android/iOS default mail apps) i see the following zpush error in the logs:

     ExportChangesICS->InitializeExporter(): Error, mapi_exportchanges_config() failed: 0xFFFFFFFF8004010F - code: 12 - file: /usr/share/z-push/backend/kopano/exporter.php:230
    

    Is there a way to fix that? Or do I have to wait for an update.

    Kind regards
    Das-Korn


  • Kopano

    HI @Das-Korn ,

    which Kopano version are you running? Do you by any chance have folders on your mobile device which are not on the server anymore?

    Please post the complete WBXML log of the request.

    Manfred



  • Same problem here.
    Could it be that latest kopano core with z-push has some issues with mariadb - not appearing with mysql?

    The whole picture:

    • MariaDB 10.3.13
    • or MySQL 8.0.15 (read on)
    • z-push 2.4.5-0
    • kopano core: latest (8.7.80.804)

    I have a large mailbox (imported from exchange server via kopano-import-pst) with a calendar with ~3000 elements that refuses to sync via z-push (iphone - same with Outlook).
    I repeatedly get the error in zpush and the sync is in endless loop (tried pairing again, forcing full sync, whatever - no chance):

    25/03/2019 12:43:17 [2740] [WARN] [mhoffmann] StatusException: ExportChangesICS->InitializeExporter(): Error, mapi_exportchanges_config() failed: 0xFFFFFFFF8004010F - code: 12 - file: /usr/share/z-push/backend/kopano/exporter.php:230
    

    From my understanding zpush connects to kopano server and this error could mean/means some problem with the store?

    So i started ICSLog for server to get some more insight.
    It turns out that nearly everytime i get the exporter error from above server returns this warning:

    Mon Mar 25 12:43:16 2019: [ 200000] MatchRestrictions: matching 1000 rows
    

    And this only happens for folders with many (too much) objects. If i delete many of them and leave only e.g. 200 it works.
    Interestingly it does not matter if i sync all, only 1 month, 1 week or 1 day. All the same. As soon as there are (my guess) more than 1000 objects in one folder it gets stuck.

    Side note: Kopano WebApp / DeskApp / ical have no problem at all - only for z-push.

    Yesterday i did dump my kopano database and reimported it into MySQL.
    All the problems seem to be gone: i can finally sync my large mailbox!

    But (my guess) exactly where the above execption occured i now get a warning:

    26/03/2019 20:52:15 [   21] [WARN] [mhoffmann] ImportChangesICS->lazyLoadConflicts(): conflict detection abandoned as there are too many (2124) changes to be exported.
    

    So, my question is - could it be that there is a certain workaround in Core or Z-Push that only works with mySQL but fails with mariaDB?
    Anyone facing the same is welcome to add some more details here.

    Of course i need to cleanup my calendar - thats not the point. But i guess that this is a bug that should be fixed as it seem to be the same situation for folders like inbox or sent items. And 1000 mails is nothing special in there.



  • I found a solution for the sync issues with z-push:
    change in kopano’s server.cfg
    enable_enhanced_ics = yes
    to
    enable_enhanced_ics = no

    and restart kopano server
    service kopano-server restart.

    NOw it works with out any error as before with mysql.



  • I got the same problem, but changing “enable_enhanced_ics = yes” to “no” does not work for me.

    I already upgraded to z-push 2.5 with no success. Afterwards I upgraded to kopano 8.7.81 with no success either.

    Z-Push works but one big calendar (our corporate cal) does produce the above mentioned errors. All I did before the errors were starting was to reboot the server yesterday.

    Any other tips how this could be solved?



  • Installing MySQL 5.7 (via Docker) and migrating the kopano-db to it solved the problem for now. Z-Push now works normal.

    Does anyone know what the problem with MariaDB and Kopano is that z-push doesn’t work - at least with folders with many entries?


Log in to reply