Kopano Core & Archiver 8.3.0 final is now available

As the name implies Kopano Core sits at the heart of every Kopano environment and is therefore a key figure in our promise to deliver stability and extensibility of Kopano’s proven communication platform. Kopano Archiver provides a way to minimize primary mailboxes by moving older messages to slower (and presumably cheaper) storage. Kopano Archiver consists of additional components that allow running Kopano servers dedicated on slower storage for archived messages whilst keeping them available transparently to the user.

Read more

@fbartels
Hi Felix,

tried the update on Univention 4.1 with the repo enabled - but getting certificate error
on Univenton 4.2 it works as expected !

any hints on this

rg
Christian

@externa1 what kind of certificate error?

Do you mean something like this, which I see on Debian 7 (but not with Debian 8):

W: Failed to fetch https://download.kopano.io/supported/core:/final/Debian_7.0/./Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

Hi Felix,

following error on all 4.1 installations

Fehler https://download.kopano.io  Packages
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

W: Fehlschlag beim Holen von https://download.kopano.io/supported/core:/final/Univention_4.0/Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLf
ile: none

E: Einige Indexdateien konnten nicht heruntergeladen werden. Sie wurden ignoriert oder alte an ihrer Stelle benutzt.

what I’ve seen is an update of the kopano4ucs package on 4.2 which is not available for 4.1 this time maybe thats the cause ?

on 4.2 it is 0_1493310199664_upload-2be8c405-7735-41c0-8e36-ecb5d1652c4a

and on 4.1 it’s
0_1493310263711_upload-7e6b0cef-0c0f-449d-855a-3ef20391f061

rg
Christian

The custom compiled mapi.so (against php 5.6.30) that I always was able to compile and use with kopano’s redhat branch is no longer loading!

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/mapi.so' - /lib64/libkcinetmapi.so.0: version `KC_8.3.0' not found (required by /usr/lib64/php/modules/mapi.so) in Unknown on line 0 

What has changed since 8.3.0~1007? 1030 and 1042 are producing the above error … WebApp and Z-Push services are down as they are dependant on mapi.so :( :(

@klausade said in Kopano Core & Archiver 8.3.0 final is now available:

Do you mean something like this, which I see on Debian 7 (but not with Debian 8):

I see this now as well. Have contacted our internal it to look after it.

@externa1 no the different versions are not the cause if this. but are you running with the test appcenter? 1.3 is not officially released yet.

@fbartels I have also filed a supportticket for this.

@fbartels
Hi Felix,

yes the UCS 4.2 is configured with the Test-Appcenter
what I’ve seen is that the cert on kopano.io has changed a vew weeks ago maybe thats causing the error ?

rg
Christian

@externa1 actually on Wednesday, but yes it looks like that is the reason for the error message.

@fbartels Yes, I am aware of this commit as I spent several hours yesterday scrambling over the KCs and commits trying to figure out what happened, however, after reverting the changes made in the commit I was still facing problems with mapi.so so it is something else.

I’ve created support ticket KS-37572 for this particular purpose and would appreciate having it escalated internally on a priority basis as z-push and collab are down.

@Wiz I have forwarded your message to our support.

Hi,

I also see this certificate error on Debian 7:

Ign https://download.kopano.io ./ Translation-en
Ign https://download.kopano.io ./ Translation-en
Err https://download.kopano.io ./ Packages
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Err https://download.kopano.io ./ Packages
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
Err https://download.kopano.io ./ Packages
  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none
W: Failed to fetch https://download.kopano.io/supported/core:/final/Debian_7.0/./Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

W: Failed to fetch https://download.kopano.io/supported/webapp:/final/Debian_7.0/./Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

W: Failed to fetch https://download.kopano.io/supported/mdm:/final/Debian_7.0/./Packages  server certificate verification failed. CAfile: /etc/ssl/certs/ca-certificates.crt CRLfile: none

E: Some index files failed to download. They have been ignored, or old ones used instead.

Any ideas how to sove this error?

Walter

Hi,

uptate to V 8.3.0 on SLES 12, is not possible, zypper always reports “Nothing to do.”

# zypper in kopano-server-packages
Refreshing service 'SUSE_Linux_Enterprise_Server_12_SP1_x86_64'.
Refreshing service 'SUSE_Linux_Enterprise_Software_Development_Kit_12_SP1_x86_64'.
Refreshing service 'Web_and_Scripting_Module_12_x86_64'.
Loading repository data...
Reading installed packages...
'kopano-server-packages' is already installed.
No update candidate for 'kopano-server-packages-8.2.1.531-8.1.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.

Download center provides version 8.3.0.

Any ideas how to fix this issue?

I already found the solution for SLES12SP1, “Auto Refresh” was disabled.

@WalterHof You could work around this with the following line, in eiter /etc/apt/apt.conf or a file in /etc/apt.cond./
Acquire::https::download.kopano.io::Verify-Peer “false”;

I wish Kopano would just fix their end. I don’t recommend this fix, setting verify-peer to false is not the way to go.

Hello,
I’ve got to say, that on UCS 4.1 this is a complete mess with the repo enabled. I’ve completely lost the clue on what version is provided through which channel.
Something is in “App Center-Aktualisierungen”, something in “Paket-Aktualisierungen”.

"Es sind App Center-Aktualisierungen verfügbar.

Kopano Core: Version 8.1.1.10-8.1-2 kann auf 8.1.1.10-8.1-3 aktualisiert werden
Kopano WebApp: Version 3.2.0.335-19.1 kann auf 3.2.0.335-19.1-2 aktualisiert werden
Z-Push for Kopano: Version 2.3.5 kann auf 2.3.6 aktualisiert werden"

The “Paket-Aktualisierungen” sometimes show something, sometimes they don’t. Klicking on “Install” sometimes does something, sometimes it doesn’t.

What should be the correct, latest Version for Core, WebApp and Z-Push now for UCS 4.1?

@fbartels is it possible, that the UCS appcenter does not reflect the updated versions of Kopano Core installed through “Paket-Aktualisierungen”?
Since Kopano Deskapp is stating “Kopano Core: 8.3.0-1042”, while UCS is still on 8.1.1.10-8.1-2 and offers 8.1.1.10-8.1-3.