How to install Kopano on Ubuntu Server 18.04

Hi Kopano friends,

I’m using right now Zarafa4h which flyies from Tosoboso via Fbartels into the Synology Community. Unfortunately the development is not as fast as the original Kopano and so we stuck at Zarafa (which is nice as well). For me it’s time to move on because it was never easy to upgrade or to restart your synology.
So I set up on my esxi 6.5 a virtual machine with Ubuntu Server 18.04.

And now is the question how do I set up Kopano?

I already accepted the Switch from CentOS 7 to Ubuntu for this Server because of the package dependencies.

Unfortunately I recieve again with Ubuntu at the installation errors because of missing dependencies.

This manual: https://www.pc-howto.com/kopano-der-neue-stern-am-groupwarehimmel-teil-1/#comment-152876 doesn’t help me.

@fbartels Your command concering “apt-ftparchive packages . | gzip -9c > Packages.gz && echo „deb file:$(pwd) ./“ > /etc/apt/sources.list.d/kopano.list” can you explain that step-by-step?

Thanks for any help!
Best Regards,
Marc

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

Ubuntu Server 18.04

I did not realise we already publish these for the master branch, but apparently we do.

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

I already accepted the Switch from CentOS 7 to Ubuntu for this Server because of the package dependencies.

Care to elaborate on that? The majority of our users use Debian based systems (and that would be my personal preference as well), but there are also users on CentOS so its not impossible to install there either.

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

I recieve again with Ubuntu at the installation errors because of missing dependencies

The errors would be good to know so these can be fixed.

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

can you explain that step-by-step?

This creates a local package repository you can use to install Kopano from.

It was just my disappointement about CentOS don’t worry. I’m fine with Ubuntu.

The following lines are showing my last tests:

libtidy5-dbgsym_5.1.9+3.1_i386.deb
libvmime-dev_0.9.2+14.2_i386.deb
libvmime-kopano1_0.9.2+14.2_i386.deb
libvmime-kopano1-dbgsym_0.9.2+14.2_i386.deb
php7-mapi_8.6.80.752-0+85.1_i386.deb
python2-mapi_8.6.80.752-0+85.1_i386.deb
python3-mapi_8.6.80.752-0+85.1_i386.deb
tidy-html5_5.1.9+3.1_i386.deb
Bearbeitung wurde angehalten, da zu viele Fehler auftraten.
root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# apt-ftparchive packages . | gzip -9c > Packages.gz && echo „deb file:$(test) ./“ > /etc/apt/sources.list.d/kopano.list
root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# apt-update
apt-update: command not found
root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# apt-get update
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# apt install kopano-server-packages
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# dpkg -i *.deb
dpkg: Fehler beim Bearbeiten des Archivs gsoap_2.8.62-0+1.2_i386.deb (–install):
Paket-Architektur (i386) passt nicht zum System (amd64)
dpkg: Fehler beim Bearbeiten des Archivs gsoap-dbg_2.8.62-0+1.2_i386.deb (–install):
Paket-Architektur (i386) passt nicht zum System (amd64)
(Lese Datenbank … 73504 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von gsoap-doc_2.8.62-0+1.2_all.deb …
Entpacken von gsoap-doc (2.8.62-0+1.2) über (2.8.62-0+1.2) …
dpkg: Fehler beim Bearbeiten des Archivs kopano-backup_8.6.80.752-0+85.1_i386.deb (–install):
Paket-Architektur (i386) passt nicht zum System (amd64)
dpkg: Fehler beim Bearbeiten des Archivs kopano-bash-completion_8.6.80.752-0+85.1_i386.deb (–install):
Paket-Architektur (i386) passt nicht zum System (amd64)
dpkg: Fehler beim Bearbeiten des Archivs kopano-client_8.6.80.752-0+85.1_i386.deb (–install):
Paket-Architektur (i386) passt nicht zum System (amd64)
dpkg: Fehler beim Bearbeiten des Archivs kopano-common_8.6.80.752-0+85.1_i386.deb (–install):

that because you need to separate the i386 and amd64 packages.

I use a script like this, I place all file in the same folder as this script and run it.

#!/bin/bash

# Updater for the local apt-repo
ARCH="$(dpkg --print-architecture)"

if [ "${ARCH}" = "amd64" ]; then
    if [ ! -d amd64 ]; then
        mkdir amd64
    elif [ "${ARCH}" == "i386" ] || [ "${ARCH}" == "i686" ]; then
        if [ ! -d i386 ]; then
            mkdir i386
        fi
    fi
fi
# Create arch based folder.
if [ "${ARCH}" = "amd64" ]; then
    mv -n *_amd64.deb amd64/
    mv -n *_all.deb amd64/
    rm *.deb
elif [ "${ARCH}" == "i386" ] || [ "${ARCH}" == "i686" ]; then
    mv -n *_i386.deb i386/
    mv -n *_all.deb i386/
    rm *.deb
fi

# Create the Packages file so apt knows what to get.
apt-ftparchive packages ${ARCH}/ > ${ARCH}/Packages

in addition use this apt line :

deb [trusted=yes] file:/home/kopano/apt/ amd64/

pointers here are.
the base folder is :/home/kopano/apt/
and in that folder we create the $ARCH folders.

Advantage with a setup like this, is its very easy now to switich to a http repo and very easy to add an extra os, and arch.

@thctlo said in How to install Kopano on Ubuntu Server 18.04:

that because you need to separate the i386 and amd64 packages.

you really don’t need that.

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

libtidy5-dbgsym_5.1.9+3.1_i386.deb

why would you want to install 32bit packages anyways? in todays world you allways want to go for 64bit.

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# apt install kopano-server-packages
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
root@svgwma-kopa-01:/tmp/core-8.6.80.752_0+85-Debian_9.0-i386# dpkg -i *.deb

it seems there is a wrong line in your sources file. if that is properly set up, then you also don’t need to to dpkg -i

PS: please use code blocks when pasting console output. this forum uses markdown for formatting.

@fbartels why are you saying that you wont have to split the amd64 and i386 package, if you dont you get a mess and this will result in errors.
Yes its possible but how may have setup Multi-arch?

Felix, please note, im not attacking here, im in learing mode If im wrong here, please point me to the source info…

It wasn’t an attack from my side either. If you are running 64bit (which you should definitely do), then only download the 64bit archive and create your repo from there. There is no need to download the 32bit archive and therefore no need to separate the repo.

And even if you provide a repository with 32 and 64bit packages I am not sure if it makes a difference to put the packages in different sub directories.

Great ;-), Always remember me as in, thctlo is trying to help not flame… i do that for you also. ;-)

Ok, yes, clear, im totaly pro dropping 32bit, saves lots of hassle… but some users still might want a 32bit version, think in the small media pc’s. like a Pi low power devices… I think a few years and 32bit is gone.

If you provide a repo with 32 and 64bit package you must split these, if these are mixed, the package cant determine what to install and the install will fail.
I have also a few 32bits servers. If i put all packages in one folder and done make the separation in arch, packages fail when installing. I provide Debian samba packages for people on the samba list, i also learned the hardway …
that how i know for sure… The samba and debian devs are great help in learning things like this.

Thanks for your answers.
I downloaded now the 64bit version. It was a mistake (for me) I usually use 64 Bit.

cd /tmp
wget https://download.kopano.io/community/core:/core-8.6.80.760_0%2B90-Debian_9.0-amd64.tar.gz
cd core-8.6.80.760_0+90-Debian_9.0-amd64

Now I probably have to do this command:

apt-ftparchive packages . | gzip -9c > Packages.gz && echo „deb file:$(pwd) ./“ > /etc/apt/sources.list.d/kopano.list”

What do I need to write into (pwd) ? A password for the package?

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

Debian_9.0-amd64

but that is now Debian 9. not Ubuntu 18.04

@hispeed said in How to install Kopano on Ubuntu Server 18.04:

What do I need to write into (pwd) ? A password for the package?

just leave it as it is. this part will be replaced by the current directory by bash (http://tldp.org/LDP/abs/html/commandsub.html).

Yes you’re right. So once again:

cd /tmp
wget https://download.kopano.io/community/core:/core-8.6.80.760_0%2B90-Ubuntu_18.04-amd64.tar.gz
tar xfvz core-8.6.80.760_0+90-Ubuntu_18.04-amd64.tar.gz
cd core-8.6.80.760_0+90-Ubuntu_18.04-amd64
apt-ftparchive packages . | gzip -9c > Packages.gz && echo „deb file:$(pwd) ./“ > /etc/apt/sources.list.d/kopano.list”

and now I need to start the installation…? Which command do I use now?

When I do apt update:

root@svgwma-kopa-01:/tmp/core-8.6.80.760_0+90-Ubuntu_18.04-amd64# apt update
N: Datei »kopano.list”« in Verzeichnis »/etc/apt/sources.list.d/« wird ignoriert, da sie eine ungültige Dateinamen-Erweiterung hat.
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
root@svgwma-kopa-01:/tmp/core-8.6.80.760_0+90-Ubuntu_18.04-amd64#

look here : https://documentation.kopano.io/kopanocore_administrator_manual/installing.html#installation
and if the repo works:

apt install kopano-server-packages 

and what i do after,

RANDOMPASSWD(){ < /dev/urandom tr -dc _A-Z-a-z-0-9 | head -c${1:-16};echo; } 

or run this on CLI or put it in .bashrc ( and type source .bashrc or logout/login again )
With the latest versions of kopano the (most) of the defaults are ok.

After the install create the kopano database. Read the manual, or use this more easy way, in my optionion.

##### Setup the Database
# Set a random mysql password.
SQLDBPWD="$(RANDOMPASSWD)"
##### Create database and set rights. 
mysql --defaults-file=/etc/mysql/debian.cnf -Bse "CREATE DATABASE dbkopano"; 
mysql --defaults-file=/etc/mysql/debian.cnf -Bse "CREATE USER ukopano@localhost IDENTIFIED BY '$SQLDBPWD'";
mysql --defaults-file=/etc/mysql/debian.cnf -Bse "GRANT all ON dbkopano.* TO 'ukopano'@'localhost' IDENTIFIED BY '$SQLDBPWD'";

ukopano = user
dbkopano = database name

change the “secret key in kopano-presence”

sed -i "s/#server_secret_key = GEHEIM/server_secret_key = $(RANDOMPASSWD)/" /etc/kopano/presence.cfg

@fbartels, the above options can also be used to create the sql database at install.

If I do your command for the installation I get this error:

root@svgwma-kopa-01:/tmp/core-8.6.80.760_0+90-Ubuntu_18.04-amd64# apt install kopano-server-packages
N: Datei »kopano.list”« in Verzeichnis »/etc/apt/sources.list.d/« wird ignoriert, da sie eine ungültige Dateinamen-Erweiterung hat.
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
N: Datei »kopano.list”« in Verzeichnis »/etc/apt/sources.list.d/« wird ignoriert, da sie eine ungültige Dateinamen-Erweiterung hat.

So probably is something wrong with the repo. It’s a fresh installation and I have only installed LAMP. I have not made any other changes to the system.

@hispeed

ok, i’ll make it more easy for you. Follow this to the letter.

mkdir -p /home/kopano/amd64
mv /tmp/core-8.6.80.760_0+90-Ubuntu_18.04-amd64/*.deb /home/kopano/amd64/
cd /home/kopano
apt-ftparchive packages amd64/ > amd64/Packages
echo "deb [trusted=yes] file:/home/kopano amd64/" > /etc/apt/sources.list.d/kopano-com.list
apt update
apt install kopano-server-packages

That should do it.

Please note that after a reboot your /tmp is empty and the folder core-8.6.80… is gone and you wil have message on every apt update

Unfortunately it is still not working. The problem must be in the following file:

/etc/apt/sources.list.d/kopano.list
„deb file:/home/kopano/amd64/core-8.6.80.760_0+90-Ubuntu_18.04-amd64 ./“

This is the error i get:

root@svgwma-kopa-01:/home/kopano/amd64# apt update
N: Datei »kopano.list”« in Verzeichnis »/etc/apt/sources.list.d/« wird ignoriert, da sie eine ungültige Dateinamen-Erweiterung hat.
E: Typ »„deb« in Zeile 1 der Quellliste /etc/apt/sources.list.d/kopano.list ist unbekannt.
E: Die Liste der Quellen konnte nicht gelesen werden.
root@svgwma-kopa-01:/home/kopano/amd64# nano /etc/apt/sources.list.d/kopano.list

@hispeed the quotes in your posts look weird. maybe that is actual a unicode quote? I’d recommend to just copy & paste the above examples.

I set up a new server again because i probably messed around to much.

So far everything is fine.

mkdir -p /home/kopano/amd64
cd /home/kopano/amd64
wget https://download.kopano.io/community/core:/core-8.6.80.760_0%2B90-Ubuntu_18.04-amd64.tar.gz
tar xfvz core-8.6.80.760_0+90-Ubuntu_18.04-amd64.tar.gz
cd core-8.6.80.760_0+90-Ubuntu_18.04-amd64
cd /home/kopano
apt-ftparchive packages amd64/ > amd64/Packages
echo "deb [trusted=yes] file:/home/kopano amd64/" > /etc/apt/sources.list.d/kopano-com.list
apt update
apt install kopano-server-packages

@fbartels you wrote about the " which were looking strange to you. It comes from copy paste from your comment:

https://www.pc-howto.com/kopano-der-neue-stern-am-groupwarehimmel-teil-1/#comment-152876

Thanks for your help, Core installation successfull with those steps.

Good to see it works now.

So the full “copy past part” is the following for others…
And you only need to change the filename/version for new versions.

if [ ! -d /home/kopano/amd64 ]
then
     mkdir -p /home/kopano/amd64
fi
cd /home/kopano/

wget https://download.kopano.io/community/core:/core-8.6.80.760_0%2B90-Ubuntu_18.04-amd64.tar.gz
tar xfvz core-8.6.80.760_0%2B90-Ubuntu_18.04-amd64.tar.gz
mv core-8.6.80.760_0+90-Ubuntu_18.04-amd64/*.deb /home/kopano/amd64/

apt-ftparchive packages amd64/ > amd64/Packages
if [ ! -f /etc/apt/sources.list.d/kopano-com.list ]
then
    echo "deb [trusted=yes] file:/home/kopano amd64/" > /etc/apt/sources.list.d/kopano-com.list
fi

apt update
apt install kopano-server-packages

@ fbartels
To make the community package better accessable. How about. this.

getting the latest version not with:
wget https://download.kopano.io/community/core:/core-8.6.80.760_0%2B90-Ubuntu_18.04-amd64.tar.gz
but with :
wget https://download.kopano.io/community/core:/core-8.6-latest-Ubuntu_18.04-amd64.tar.gz

This simplies getting the latest much.
Just an idee.